My regular uptime on Samsung Galaxy S2 was around 6 days. For the last couple of weeks it is down to less than 3 days. The change was instant, but I was hoping it would come back - it did not. Running ICS 4.0.3 from Samsung. No change of activity - I primarily use my phone to talk, no games, browsing etc. I installed System Tuner, looked in the system log and found this event happening every second or so: "DrReadUsbStatus returns false USB is offline" Similar problem on the internet:

According to some sources, it could be causing battery life issues.

Samsung suggest a hard reset - trying to avoid that at all costs.


The error seems like something regular. A Google Search reveals many places it is mentioned (with a logcat), but almost nowhere it is commented on -- except for GALAXY W Constant Error in Logcat (XDA).

A shame they removed the wakelock stats from *#*#4636#*#* service menu (which would have offered you a quick way to check) with Gingerbread and up. You might want to look for some monitor app on the market (there's e.g. SystemPanel which might prove helpful) to figure out what keeps your device awake.

In case this app doesn't provide the required information (I already mentioned Wakelocks being the most probable cause), there's another useful app: BetterBatteryStats (also mentioned in the XDA-Link) seems to bring back Wake-Lock stats. As a short and eased-up explanation: An app might request the CPU not going to sleep, but still not actually use the CPU, though - the Android PowerManager API provides an interface for this). So BetterBatteryStats should help you find the responsible app:

BetterBatteryStats: Kernel Wakelocks BetterBatteryStats: Partial Wakelocks

For reference, here's the link to the BetterBatteryStats Thread on XDA, including the App (and its Changelog) as well as some closer explanation, especially on Wake-Locks.

  • It does not seem like any app is eating battery. I ran a recording in System Tuner, taking samples every 20 minutes for 24 hours; here is what it says: CPU utilization 19m 49s, Android System 8m 59s, Fancy Widgets 3m 49s, System Tuner Pro 1m 39s, System UI 1m 20s, Settings 55s, WidgetLocker 39s, everything else is less than that. Hard to explain, unless there is a hidden process, which it does not show. SystemPanel does not seem to add any useful information to that. Is there a way to repair Android installation somehow, so maybe it will fix this USB issue?
    – Neolisk
    Aug 11 '12 at 18:24
  • 1
    I don't think it's really CPU usage, rather some app keeping it alive by requesting "Wake-Locks". I will update my answer now with a few more informations.
    – Izzy
    Aug 11 '12 at 18:41
  • Installed BetterBatteryStats - measuring "Other" since unplugged (since 7 h 10 m 22 s) - No Data Connection ratio 100%, no or unknown signal ratio 100%, wifi on 38.1%, wifi running 38%, everything else is less. Kernel wakelocks - no events catched. Partial wakelocks - ConnectivityService count:586, NetworkLocationLocator:89 - is it where the problem lies?
    – Neolisk
    Aug 11 '12 at 21:27
  • Update for partial wakelocks - ConnectivityService count:722, seems to be happening quite often.
    – Neolisk
    Aug 11 '12 at 22:49
  • 1
    This also matches with your initial suspection: USB is part of connectivity. Maybe a developer could tune in here and say if ConnectivityService and DrReadUsbStatus belong together? As you're running an official ROM supplied by Samsung, I'd confront the service with these details. They will probably want you to factory reset, so use that chance to tell them they should include Titanium Backup (or any equivalent solution if there is) with their official ROM next time, so you wouldn't lose any data...
    – Izzy
    Aug 11 '12 at 22:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.