When I want to type in a location to get directions, Google Maps brings up a list of suggestions under the textbox. That's fine, but then when there's only one suggestion left, Google Maps overrides what I was typing with that (invariably incorrect) suggestion. This makes it all but impossible to actually put what I want because even if I go back and edit, Google Maps will just clobber my text again. How do I make it stop? I don't see anything under Settings, either in the phone or the app.

I'm on a Samsung Galaxy S3. It would be ideal if I could keep the suggestions under the box without the automatic completion, but I'd settle for just turning it all off.

1 Answer 1


Ok, I found a workaround. I am calmer now.

Use Spiffy Search from the Market. You can use it to search, then have it set to maps. It doesn't use your internet connection.

Then, edit maps settings so that the navigation icon appears whenever you find a location.

My deliveries just became a little easier!

Btw, I use a Droid X on Page Plus, which uses Verizon's network. For 30 dollars, I have vzw coverage, which is essential on my job, 1200 minutes and 3000 texts, but only 100 mb of data, which is why I am so obsessed with conserving it. Now with this work around, I can email, websurf with opera mini, and navigate without going over my limit. It is a brilliant way to milk the big V for all they are worth!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .