I'm so sorry for being one of these "help me, I don't know what to do!" noobs, but that's exactly my situation. This is my first Android phone and my first time trying to do this. I do come from a programming background, so I didn't anticipate it giving me any trouble.

I have a Droid Razr and I had Gingerbread 2.3.6 on it before I rooted it. After the root, it started giving me notifications for the 6.1...something update, but since I rooted it, the update wouldn't take.

I tried to put Eclipse ICS ROM on it. First, I backed up my apps, put Safestrap into safe mode, and created a backup. I followed the directions here for flashing the ROM. I waited about 5-10 minutes after rebooting - the Motorola logo came up on my phone, followed by the Safestrap boot options, then nothing.

I rebooted and got into the Safestrap menu and tried to restore my backup ROM. The restore failed. I tried formatting the device through Safestrap and it still didn't start up.

I followed the directions here up to step 7 to unroot/unbrick. This uses Droid Razr Utility 1.42, and everything I tried came back with a "command failed" message. I thought it was a little strange that the only option it was giving me was to restore version 6.12.173 while I had 2.3.6, but I figured I would at least try it, and I thought that was why I was getting the "command failed" message. After googling, I downloaded Droid Razr Utility 1.8 and tried restoring it to 6.16.211 (official kernel) - again, the only option it gave me.

After that, I can no longer enter Safestrap. The phone doesn't boot - it goes through the Motorola logo and then shows a small bar of static right at the bottom of the screen. Fastboot recovery and restoring the phone to factory settings makes an error show up on the screen (the Android mascot and an exclamation point in a triangle).

I can still enter into Android recovery and I still have access to the contents of my SD card. I can see the folder where my Safestrap backup should be, but there's nothing in there that the phone recognizes as bootable. I can still also access the Eclipse.zip file. I haven't tried flashing it again.

I don't know what's going on or what to do next. Any help would be greatly appreciated.

  • I don't have a full answer for you. But since you can get in to the recovery, you might be able to find a custom ROM (for the RAZR) that can be loaded via the recovery. Aug 12, 2012 at 5:40
  • I don't have a complete answer for you either, though I can say that the step you missed was installing the ICS OTA (6.16.211) prior to attempting a custom ICS ROM. This seems to be a quirk of the DROID RAZR. Aug 12, 2012 at 17:25

1 Answer 1


Well, If you would have read the instructions for the installation of Eclipse ICS, you would have seen that you're not to install the ROM on top of Gingerbread.

That being said, have no fear. Batman is here to save you. Check out the trusty internets and get you a copy of this file.


You will need to run this utility to restore back to factory ginger bread (option 1 I believe).

There are guides for this online. I can't find the source right now. Basically you put the phone into ap fastboot mode while Matt's utility flashes it back to factory. then if you so desire, you can take the OTA ICS update. Only then can you install safestrap and eclipse ics.

Hope this helps.

  • 3
    Could you point to that utility directly instead of hinting at google searching? Seems like you solved this already.
    – ce4
    Aug 22, 2012 at 20:54
  • @ce4 a new user cant post links
    – samsung
    Jan 9, 2015 at 6:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .