On the Motorola Droid I was successfully getting my corporate email for a year with no problems. On 11/09/2010 I started getting a security error when trying to retrieve email in the native Android Mail app. I tried tweaking a couple settings but ended up deleting my account credentials in order to re-enter them in an effort to bypass the security error. I know get an error every time I enter my account credentials and attempt to connect to our corporate exchange server.

I go through the following steps:

Open the mail app Enter email address and password Press Manual setup Press Exchange Modify Domain\Username and Server to contain correct corporate information Insure "User secure connection (SSL)" and "Accept all SSL certificates" are checked Press Next App says "Checking incoming server settings" Message pops up "Sorry! The application Email (process com.android.email) has stopped unexpectedly. Please try again."

No combination of rebooting, clearing Mail app data and changing of SSL selections allows me to bypass this error.

UPDATE According to Motorola Level 2 technical phone support the only solution to this issue is to restore the phone to it's factory settings.

  • Worse case scenario you could try a factory restore. Make sure you backup everything first (if you are rooted, see TitaniumBackup)
    – Bryan Denny
    Nov 10, 2010 at 15:24
  • That's odd I had the same thing happen to me on my Droid 1, after a few try's it worked. I wish I knew what was different on that last attempt, sorry it was a couple months ago... Dec 27, 2010 at 21:48
  • Hi Andy, probably too late, but problems like these make excellent bug reports. If you can reproduce it and it force closes, then you should have downloaded something like Logcat from the Market and copied the bit of the log that has the error at the time when it force-closes, and report/paste it at b.android.com. Developers like me need this kind of info to improve the system, otherwise people keep running into this and everybody has to factory reset. Another way is a little persistance at Motorola's helpdesk. If it reproduces they should have taken a look at it if you ask me. Easy debugging!
    – pjv
    Mar 7, 2011 at 19:54
  • This question should probably be closed as it is already solved and it is not clear what the question was.
    – pjv
    Mar 7, 2011 at 19:59
  • Just a workaround suggestion but maybe you should give k9mail a test run. It is better for integration with corporate type mail servers than the stock client. Mar 24, 2011 at 20:26

1 Answer 1


Andy appears to be gone, so I'm going to post the answer since the problem is solved.

According to Motorola Level 2 technical phone support the only solution to this issue is to restore the phone to it's factory settings.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .