I have read every forum and every "help" site on Samsung's website and all over the internet. Nothing has worked. I bought an unlocked Galaxy S i897 on ebay, originally an AT&T phone but I'm using it on T-mobile. Is this potentially the problem? I've tried 2 different cords, only charges, never recognized in any Kies version and never recognized by PC like step 3 on this page says it should.


Extremely frustrated at this point. I don't think calling t-mobile can help because the phone was AT&T. Samsung probably wouldn't help either because I bought it on ebay. Unless you think they would, then let me know. I just want to add music and transfer files back and forth, backup contacts, etc., and most importantly update my firmware (currently has Froyo).

  • What OS version do you have? – Zuul Aug 12 '12 at 18:20

Apart from potential issues from your current OS version, installed drivers, etc, you can look at this problem from your phone's side.

Assuming that the problem doesn't lie with Kies, Windows 7 or the drivers in use:

  1. Before connecting your phone to the computer, open the keypad and dial *#7284#;
  2. You will see a menu for UART and USB;
  3. Under USB, select PDA. If PDA is already selected, select MODEM and then back to PDA;
  4. Don't worry about USB debugging or anything, just connect your phone to the PC Everything will work as it is intended to whether you use Kies, no Kies or just Mass storage.

This is a known problem with Samsung, the PDA mode for the USB connection needs to be active. And when active, sometimes we need to reset it by selecting something else and then PDA again.

  • Thank you for an answer that is finally not just another forum with the same "solution". But it didn't work. So what are some of the other factors that could be causing it that I can look into? – pferdesindgut Aug 13 '12 at 4:36
  • I have Windows 7 home premium version 6.1 SP1 – pferdesindgut Aug 13 '12 at 4:44
  • @pferdesindgut Can you specify which part didn't work? You dial the code and the menu was presented and you've selected an option and after connecting the phone to your PC again, It wasn't recognized? Or the menu wasn't presented when the code was dialed? – Zuul Aug 13 '12 at 8:46
  • I dialed the code, plugged into PC again, and it was still not recognized. – pferdesindgut Aug 27 '12 at 4:24

Please download and install the Samsung drivers - if you're using a 64 bit computer, use the 64 bit drivers, otherwise use the 32 bit version.


What type of OS do you use? On W10 Home it simply does not work, try on any W10 Pro. I had the same issue before, very annoying :(

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.