The company I am working for has hundreds of Galaxy Nexus handsets which are used as the standard operating platform of a company specific app. The app is not important.

We have found that about 70% of the devices fail to install the standard OTA Jelly Beans update. We are running completely stock OS (4.0.4 ICS) and the devices are not rooted.

My questions are:

  1. Why does the OTA fail for completely standard builds? Factory reset makes no difference.

  2. How can I get some idea as to why the OTA fails?

  3. Where does Google provide support for this situation?

  4. Can I disable the OTA updates? We are getting very frustrated with the regular interruptions to normal service when the OTA notification pops up no matter what the user is doing.

  5. Is there a Google web site that describes how to do the OS update manually? Perhaps we can manually handle the hundreds of handsets, costing us thousands of dollars in labour costs?

I have reported this to the code.google.com Android issues list, no response from that.

I tried to post a notice on Android Developers but the moderation process there seems to take four or more days, perhaps never.

This must be happening tothousands of non-developer users of the Galaxy Nexus, they can not be expected to hack their way around it. Where is the Google fix (or does Google simply not care?).

  • How does the update fail?
    – Flow
    Aug 13, 2012 at 8:37
  • It starts the upgrade, showing the Android with the rotating dodechedron for about 10 seconds, then the Android lies down on its back with the stomach still open and an exclamation mark warning sign over the open door, and then the screen goes blank, the phone reboots and it still has the old 4.0.4 software.
    – David Ross
    Aug 13, 2012 at 8:40
  • I believe that there is log file created while the system is in recovery/update mode. But I am not sure where, maybe /data/cache/recovery/log, (would need root).
    – Flow
    Aug 13, 2012 at 8:47
  • The only way I know of to disable the OTA updates requires root. It sounds like your phones are unrooted. If that's not the case, let me know and I can at least leave a partial answer with how to do that.
    – SaintWacko
    Aug 13, 2012 at 15:46
  • @Flow AFAIK, /cache would have been remounted under /data directory, some ROMs do that?
    – t0mm13b
    Aug 18, 2012 at 16:31

1 Answer 1


Try the old trick of doing this, from ICS, tap on Settings > Apps, tap on the tab called 'All', look for 'Google Services Framework', then tap on 'Clear Data', you may need to do this a few times and restart the handset.

This is known to work with the Galaxy Nexus line of handsets.

  • Thanks Tommie, still doesn't work. What happens to all the non-technical GN users out there? They must find the reminders and failures very irritating. I find the silence from Google very irritating.
    – David Ross
    Aug 21, 2012 at 1:53
  • I've been having this same problem, except I am running stock Jelly Bean 4.1.1 (which is rooted) and I'm trying to update to 4.1.2. Will clearing data for Google Services Framework affect any of my data? Oct 26, 2012 at 3:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .