I own a Motorola Milestone 2, also called A953 (apparently this is different from the Droid 2 Global). It used to have Android 2.3 with Motoblur middleware. It was bought independently from any phone carrier (so it was not bought from Verizon for instance). I rooted it, installed ROM Manager, Droid 2 Global Recovery Bootstrap and ClockworkMod Recovery. From ROM Manager, I could successfully reboot my phone into Recovery mode, allowing me to back-up my data for instance. Until this stage everything went fine.

What lead to my problem : I also wiped the cache and installed CyanogenMod 7.2 and the Google apps from ZIP files and from the Recovery Mode interface. But now my phone is broken. When it now boots, it shows the stylised M logo, but then switches to an entire black screen. The phone is still on so I have to pull the battery to shut it down.

I would like to reboot into Recovery Mode but this doesn't work : I am never able to see the Recovery Mode logo (a warning sign with a little android). How should I do it ?

What I have tried : I tried to boot while holding the Power and the 'X' button, as adviced on different forums. This still leads to the black screen. At this state, pressing the Search hardware button does nothing. Holding the Power and the Volume Up button has no more effect. I am able to enter Bootloader Mode by holding Power and Up Arrow. Procedure suggested by Verizon

I also tried to use a live CD from here with ezSBF, but I get errors in the process and then my phone reboots in Bootloader mode and shows the following error:

Critical Error:
FEBE 0047

After that I still cannot get to Recovery Mode.

  • For instance, does anyone know a better hotkeys combination ? Or could I use ADB ?
    – Agmenor
    Commented Aug 14, 2012 at 1:37

5 Answers 5


Is it unplugged when trying to do this? I could hold X while booting, then I would see the Android and exclamation. Then hold Up/Down Volume and get the recovery. You have to press both Up & Down at the same time. It is not a rocker key and you can press them both. Use Enter key on keypad with the arrow above OK to make a selection.

  • +1 for the "up/down together" hint. My stone was caught in a boot-loop, so the "x" didn't help. Has CyanogenMod and TWRP installed. Shortly after boot starts, the LED lit up blue (which is when it's waiting for keypresses; I'd tried up, next time down, without success) – this is when to press both volume keys. Got me to recovery (via boot menu), and I was able to wipe cache/Dalvik to kick it out of the loop.
    – Izzy
    Commented Sep 6, 2015 at 13:11

Boot while holding X gets you to the bootloader

Boot while holding volume up gets you to the recovery.

I myself can't get to the bootloader but can get to the recovery. (Flashed a wrong SBF, oops)


I managed to do it using help from XDA-Developers. Here is the procedure :

  1. Download the best SBF file from here. Among those corresponding to your geographical region and carrier, choose the most recent one.
  2. Flash it to the phone by using either "sbf_flash" if you are on Ubuntu, OSX or another Linux, or by using "RSD Lite" if you are on Microsoft Windows.

The result is that the phone is unbricked. Among other things, I now can go back to Recovery Mode.


Power up while holding the X and when you see the yellow exclamation mark after the Moto Logo, hold Vol Up+Down. That should get you to the Recovery Screen.

  • As I said in the question, "I tried to boot while holding the Power and the 'X' button, as adviced on different forums. This still leads to the black screen". Hence the GIF in the question. But thank you anyway for your participation.
    – Agmenor
    Commented Aug 22, 2012 at 23:06

Hold power key , up volume key , and home button should go to recovery mode

  • LOL It's a MOTO device, not a Samsung. No such thing as "home button".
    – Izzy
    Commented Dec 9, 2013 at 7:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .