0

Possible Duplicate:
How can I fix the GPS on my Samsung Galaxy S?

I've got a Samsung GT-I9000 (SGS1), it was on a pretty old stock firmware. I upgraded and rooted it with Odin and installed CyanogenMod 9 and the Icy-Glitch Kernel.

However I can't get any GPS signal, if I'm in Google Maps it keeps saying something like "Searching for GPS" (original on German "GPS wird gesucht").

I know that it did work with the old firmware when I got it.

What can I do to get the GPS back working?

6
  • Maybe a special CM issue. Many HTC-Buzz-Owners experienced this. Most got it fixed by (re-)flashing the radio. PS: @Flow I don't think its a duplicate, as the link you posted refers explicitly to Samsung firmware and a Samsung provided fix -- except if it does not refer to the system image (but e.g. the radio), which I could not figure out here.
    – Izzy
    Commented Aug 15, 2012 at 19:44
  • @Izzy IMHO the famous SGS GPS problem is a pure hardware issue. Most fix attempts have to do with hardware and also my answer.
    – Flow
    Commented Aug 15, 2012 at 20:09
  • @Flow Thanks for clearification! Not having an SGS, I just barely remember there was an issue several years ago with SGS & GPS, but forgot all the details ;)
    – Izzy
    Commented Aug 15, 2012 at 20:11
  • Well i know It worked For the old user of the phone (Stock). It didnt work on my old Rom either(Dark Knight 5.5).
    – theodm
    Commented Aug 15, 2012 at 20:15
  • @wayback if you are 100% sure that it worked on stock rom then it's most certainly a software issue which can be fixed by changing the rom or updating. But IIRC the GPS issues on the SGS where mostly caused by bad hardware design.
    – Flow
    Commented Aug 15, 2012 at 20:18

0

Browse other questions tagged .