I have just installed CyanogenMod and, while testing the Gallery and Photo editor apps, have noticed a very strange behavior. Whenever I try to apply some effects such as Lomo, Documentary among others, the Photo editor applies the effect only to a circle in the center of the image. The problem happens with any image from my gallery, no matter the resolution or the camera (back or front camera).

I have already rebooted the system, and have tried to "clear data" of the app. I have searched all the possible configurations and could not find anything related to this problem.

(The funny thing is that I tried an app called Photo Editor ICS, which is a clone of the original Photo Editor, and it worked fine. But I don't mean to keep using it, I expect that the original app works)

lomo effect applied to the center of the image

  • what version of CM are you referring to? – t0mm13b Aug 16 '12 at 20:27
  • CM9.0.0. Running on a Samsumg Galaxy S2 – Paulo Guedes Aug 17 '12 at 17:21

Try using Aviary instead. It's an excellent photo-editor app with even more features than the default one, and it works for me, even when I flash experimental JB roms where the camera doesn't even work.

This is a strange problem, unique to your device, and you should probably report it on the CM forums.


  • 1
    care to tell everyone else what the linky is about? – t0mm13b Aug 16 '12 at 20:22
  • ahem OK! Good tip. Thanks for not downvoting. – rm-vanda Aug 16 '12 at 20:25
  • 1
    I give other people a chance to improve themselves by going "pssstt... what's that about?" ;) – t0mm13b Aug 16 '12 at 20:28
  • Aviary seems to be a great app, but... I don't mean to pick any photo editor, I'd like to use the native one. There are many apps out there with great features, but I think it's essential that the native app works fine. Anyway the problem seems to be specific to Samsung Galaxy 2. I have seen in a friend's phone and also there are some people discussing it in XDA forum. In fact it seems to be a problem with the CM9 release, not sure if it can be corrected by a regular user. – Paulo Guedes Aug 17 '12 at 18:34
  • Right, which is precisely what I said-- This is more than likely an issue with the CM9 build for your device. Therefore, to immediately get around the issue, as opposed to waiting for a patch from the CM9 team for the SGII--- you can just use Aviary-- since it is fully featured, has the plugin capability, so you can invoke it directly from the Gallery--- etc, etc-- Would you like me to edit out the part about Aviary so that "This is a problem with CM9 on the GSII" is the correct answer? – rm-vanda Aug 17 '12 at 22:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.