I can't go on to the Google Play Store! I do not know why. Last time I did, I tried to download 'HOM 2' which is a game, and cannot download it. It says "package invalid" and "phone storage is getting low". Then a while ago, I checked again, the Google Play Store and it says "Server Error retry".

I have already cleared the data and uninstalled updates..

Then switch off and on, the phone, but still Google Play Store still does not work!

Any advice would be appreciated.

  • 2
    What phone do you have? Stock Android? What version?
    – MrWhite
    Aug 18, 2012 at 15:06
  • Is the connection not working for just the Google Play Store? Can you access the internet via a browser?
    – Darius
    Aug 18, 2012 at 15:28
  • Please check the following Q&As, which cover the topic: android.stackexchange.com/questions/15932 (Playstore) / android.stackexchange.com/questions/27127 (low storage)
    – Izzy
    Aug 18, 2012 at 20:07
  • Looks like the playstore currently has some server probs -- I just cannot even reach their website with a browser...
    – Izzy
    Aug 19, 2012 at 1:01

5 Answers 5


Usually, when the APK states "Package Invalid", that means, either the package is corrupted or the application at the most, targets the version above the currently running Android on your handset, up to the latest and greatest version of Android, in other words, the minimum version of Android was probably raised above it.

For example:

An application that targets Android 4, Ice Cream Sandwich, if the minimum version is Gingerbread (Android 2.3.7), and the maximum version is Jellybean (Android 4.1), it is compatible from Gingerbread, Honeycomb, Ice Cream Sandwich and Jellybean.

If that was attempted to be installed on either Eclair (Android 2.1) or Froyo(Android 2.2) as in the case of the OP's question, you will get that message.

TL:DR; the application is incompatible with the currently running version of Android.

  • Google Play won't allow you to install incompatible app. Many times when I have bad connection I get "Package Invalid" message but trying multiple times even over bad network works finally.
    – roxan
    Aug 18, 2012 at 16:13
  • @roxan true, but try installing it manually you will get an identical message outside of Play store :)
    – t0mm13b
    Aug 18, 2012 at 16:14
  • I think then you should include both the aspect of the problem to avoid confusion :)
    – roxan
    Aug 18, 2012 at 16:20

Try manually syncing the account you are using to install apps.. If that doesn't work try removing that account and try with other account


I agree with hunter. The hosts file may cause this problem in the play store. Deleting it solved this problem for me. You will need to be rooted to delete it.

The hosts file is at etc/hosts. If you are rooted, you can use root explorer. Go to the root directory and find the "etc" folder. Press the button on top to mount as read/write. Then find a file called "hosts" and delete it.

It should work instantly as it did for me. Hope that helps.

  • @firelord I'm not sure which entry in the hosts file causes the issue, or why. I was using adblock when I had this problem. Adblock created an unending list of entries, one of which probably caused this error. In this case, it may not necessarily be adblock that's causing it, or the hosts file at all. It worked for me and its worth a shot.
    – Theturtguy
    Jun 18, 2016 at 18:48
  • What the heck, I just realised how old this is. I suddenly feel lonely.. hope this helps other people.
    – Theturtguy
    Jun 18, 2016 at 18:50

Well you need to delete hosts file, which is done via root privileges, without root you can't delete that file and I am afraid that play store won't work without deleting this file.

  • 1
    Please explain what does hosts file has anything to do with the problem? More specifically, which entry or entries in that file are the cause of issue?
    – Firelord
    Aug 9, 2015 at 19:43

you should remove the updates of the Google playstore app, and disable automatique updates

  • 4
    How to do that? Any how would it work to resolve the issue? Please mention that as well.
    – Firelord
    Aug 9, 2015 at 19:44
  • i had the same problem on my BQ AQUARIS 5 that was running on android 4.2 and somehow the update of the playstore is not compatible with my device, so my guess is that it s the same in your case
    – java_noob
    Aug 10, 2015 at 22:26
  • 1
    @java_noob I wonder why the Playstore App on your device respects disabling the "automatic updates". Google apps are known to notoriously ignore that; so having removed the updates, you will find them back again within ~24h usually. So may I repeat Firelord's question: "How to do that?" Please edit your answer accordingly.
    – Izzy
    Sep 5, 2015 at 14:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .