First, my device failed to get the OTA Update because I deleted some system apps (see my original post).

Then I found this post where another user restored original APKs in /system/apps and managed to manually update to JB by downloading the dlpkgfile in this post.

So I proceed, restored my /system/apps (with 755 permissions), rooted with OTA RootKeeper and SuperSU, placed the dlpkgfile and command files, restarted to fastboot (Power+Vol Down) and entered Recovery mode.

The green android with the blue progress bar went for over 10 minutes, then ... the android with the RED TRIANGLE appeared

After a minute or so the device restarted, an ASUS logo with a blue progress bar ran, but then it got stuck in the ASUS logo.

I'm still able to restart to fastboot (Power+Vol Down), where a message appears:

Android cardhu-user bootloader (1.00 e) released by "US_epad-" A03

, and where I have 4 choices:

  1. RCK: Recovery mode, when I select this the Red Triangle appears again.
  2. Android: Normal android boot, gets freeze right away
  3. Fastboot USB download protocol: Tried using ADB, but don't really know what it is. Here's an image of how the device appear in my Windows PC Here's an image of how the device appear in my Windows PC
  4. Wipe Data: Already done this, seems to wipe user data, but still gets stuck on ASUS logo

Some pictures I took of my device: picture 1 picture 2

I also tried downloading .30 firmware from ASUS website and placing the Zip contents in my SD card, then booting recovery but no luck.

It's pretty awful that everything went so bad, I'm hoping there is a solution.

Anything would be really appreciated!!!



OK, I found this tutorial about flashing ASUS firmware with fastboot: http://www.theandroidsoul.com/how-to...back-to-stock/

The problem is that the following commands:

fastboot -i 0x0B05 flash system blob
fastboot -i 0x0B05 flash system US_epad-user-

both produce the error: "Signature mismatch"

I guess it's because my fastboot has newer version, since it was actually installed during the JB update, but I'm trying to flash a older .30 firmware.

I guess I will have to wait ASUS releases the new firmware for manual flashing it.

Just guessing...

More info here: http://forum.xda-developers.com/showthread.php?t=1846661

  • 3
    Download a working CWM for your device and flash it: 'fastboot boot cwm.img' or 'fastboot flash boot cwm.img' (found here or see Cyanogenmod's full update guide. fastboot flashes images only (not .zip files). After that you have a working recovery again and you can go on and flash CM9/10 or so (from here)
    – ce4
    Aug 22, 2012 at 9:35
  • I would like to remain stock and not avoid my warranty, is that possible?
    – Ben Orozco
    Aug 22, 2012 at 13:54
  • I never unlocked the bootloader or something like that. Is it possible to flash the old .30 bootloader?
    – Ben Orozco
    Aug 22, 2012 at 14:36
  • Seems like 'fastboot boot' is not working and the unlock utility (.apk) needs a running Android installation to proceed, so this is both not a working path. That leaves only 'fastboot flash recovery|boot|etc. image.img' (which needs a working and signed image.img file due to the locked bootloader (and not a .zip)). Maybe Asus provides a recovery utility and .img files (or whatever Asus names them) that can be flashed to recover your device. I however don't know how to obtain these... You might try to call their support line and get help from them.
    – ce4
    Aug 22, 2012 at 15:39

1 Answer 1


Solved. ASUS released the new firmware in its website.

Flashing it unbricked my device:

  1. Download the stock firmware from ASUS’s official website. On the website, select Android in the OS drop down menu, then select Firmware, and download the latest firmware.
  2. Extract the downloaded firmware file. You will get another archive file. Extract this one as well to get several files. One of these files will be named “blob”, which is the one we need to use.
  3. Install Android SDK for Windows.
  4. Shut down the tablet. Hold Power + Vol Down buttons until a message appears saying “Press Vol. Up to enter RCK (5s)”. However, DO NOT press the Volume Up button. Instead, wait for 5 seconds till a new menu appears. Then, in less than 10 seconds, press Volume Down once to highlight the USB icon, then press the Volume Up button to validate.
  5. Open Command Prompt on your computer from Start » All Programs » Accessories (or open Start menu, type cmd and press the Enter button).
  6. Now, type the following commands in command prompt to flash the stock ROM, pressing Enter after each command:

    > cd C:...\Path-to-Andoid-SDK\platform-tools\

    > fastboot devices

    > fastboot -i 0x0B05 flash system C:...\Path-to-blob\blob

    > fastboot -i 0x0B05 reboot

Source: http://www.theandroidsoul.com/how-to-restore-asus-transformer-tf300t-back-to-stock/

More details: http://forum.xda-developers.com/showthread.php?t=1846661

  • Nice to know you got it back working again! Would you mind to add the required steps here (instead of linking only)?
    – ce4
    Aug 22, 2012 at 18:58
  • Done! Steps added :)
    – Ben Orozco
    Aug 23, 2012 at 5:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .