Well, finally got my Nexus 7. Set up all the basics and hit a pretty big roadblock, the email account setup for IMAP simply won't work.

Just to clarify, I'm absolutely certain all the details I've put in are 100% correct, I've double-, triple-, quadruple- and so on-checked them. They are exactly the same as the settings I use on my iPhone, in Mail.app on my Mac and in Thunderbird on my laptop. All three of these devices are on the same network behind the same FreeBSD machine that does packet filtering, they are all on the same subnet and subject to the same packet filtering rules.

The IMAP(S) server is my own running on a Debian VPS and here's the kicker, when I check the logs all the other clients' connections are clearly visible but no connections from the Nexus 7 show up. The Nexus 7 has shown no other signs of network issues but whenever I try to setup an IMAP account I get Couldn't open connection to serverthrown back at me immediately (no delay indicating some kind of timeout, immediate, right away, BAM!).

So, does anyone have suggestions on how I can fix this? I've tried googling but every forum post and blog post I've come across has been so obviously about other things (most of them along the lines of "I'm trying to my email what is server?" which means the answers aren't very helpful).

Edit: I've also tried a complete factory reset but I'm still getting the same error.

Edit2: I am able to telnet from the tablet to the IMAP server and when I do so everything that should get logged in /var/log/mail.log on the server gets logged there but when I attempt to setup an account in the settings and click Next I still don't see anything in the logs. I'm starting to have suspicions that this is either something strangely broken in the the IMAP client libraries or some kind of IPv6-related screwup (since the server is accessible through both IPv4 and IPv6).

  • Did you try K9 Mail?
    – Flow
    Aug 23, 2012 at 17:06
  • Haven't tried any alternative mail clients yet, was hoping to get the default client working. Doing a factory reset right now to see what happens...
    – mludd
    Aug 23, 2012 at 17:24
  • I would try K9, just to narrow down the problem.
    – Flow
    Aug 23, 2012 at 17:30
  • Now I've tried K9 and it also insta-fails. Using the default client to connect to an Exchange server works though. K9 also isn't generating any connection attempts in /var/log/mail.log on the server...
    – mludd
    Aug 23, 2012 at 18:01
  • Ok next step, install a telnet client or nmap on your device and see if you can open a TCP connection to your IMAP Server by trying to create a telnet connection to the IMAP port.
    – Flow
    Aug 23, 2012 at 18:15

3 Answers 3


Ok, I tried restarting the IMAP server with no luck and then I decided to try a second factory reset, not that I was expecting it to work but apparently something changed because suddenly it worked and I have no idea why. Ah, the magic of user-friendliness.


The Couldn't open connection to server happened to me as well on IMAP Email set-up, then I noticed that the default IMAP server was imap.mydomain.com. So I made the following changes and it started working:


IMAP Server: mail.mydomain.com


Security type: SSL/TLS (Accept all certificates) - If I didn't change to this Security type it also gave me the Couldn't open connection to server.

This may be different for your server however.


it worked for me after I deleted google as my main account in the phone, installed gmail on exchange and reinstalled google as my main account.

  • 2
    Might be best to elaborate a bit more for the benefit of those who are new and coming on here. :)
    – t0mm13b
    Oct 11, 2012 at 20:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .