I am a new Android user, and recently I have upgraded the default ROM of Samsung Galaxy S 3 to Jelly Bean MIUI ROM using the steps mentioned at the International Business Times.

Now I want to revert it back to default ROM but I am unable to do so.

Although the blog says

If you want to return to your previous ROM for some reason, boot into recovery (using the procedure explained in step 3), choose backup and restore, then restore your previous ROM by selecting it from the list.

But I didn't find anything within the list.

I tried wipe data / factory reset but still not getting the default ROM.

What do I need to do to get back the default firmware?

  • Did you do the NANDroid Backup, as step 4 of that guide suggested? If so, did it complete successfully? It might have failed e.g. if there was not enough space left on your sdcard. BTW: A factory-reset will never revert to the previous ROM -- it just cleans up all user data, caches, etc.
    – Izzy
    Aug 26, 2012 at 21:33
  • Yes, I did so and there was about 7 gb of space left within my internal memory. I didn't noticed whether it was successful or not(may be you are right), and after that i did the factory reset, which i believe must have deleted the back-up
    – Mac
    Aug 27, 2012 at 5:47
  • Nope, factory reset doesn't delete anything on the card. Your backups should be saved there in the clockworkmod/backup/ directory. I had it once with not enough space left on the card and got no warning (although I saw it when checking those 0 byte files before I continued to the next step ;), hence that question. 7G should be more than enough, usually. My backups never exceeded 1GB. But you already found the only alternative (+1 from me) -- still you might want to look for those files, for the next time to know ;)
    – Izzy
    Aug 27, 2012 at 6:22

1 Answer 1


I found a workaround, Downloaded a firmware from http://www.sammobile.com/firmware/ and updated my galaxy s3 with that using odin. Upon first reboot my phone hangs showing only boot screen with samsung logo for about 2 hours, then I restarted phone in clockworkmod recovery did a wipe data / factory reset and then restarted the phone again, I got the default firmware back. Then connected the phone to pc using kies and upgraded the firmware.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .