I have a Google Nexus S, bought last year and it was working fine till last week. It came with Android Ginger Bread, and I rooted the phone and installed several custom ROMs including Cyanogenmod. Recently I installed Android Jelly bean ROM, and it was working fine.

Last week, I wanted to try the Cyanogedmod 10 (on Jelly bean). I went to recovery mode for taking a backup. But I saw a recent backup which was taken before 2 months. I thought that should be fine. I cleared all cache and did a factory reset for getting ready for the new ROM.

Now something went wrong!

I tried to reboot the device, but I could only see the usual animated CROSS logo( with four colours) for ever. I even left the phone for more than a hour. But it is not rebooting. //SO CAN'T RELOAD THE PREVIOUSLY WORKING OS

I tried restoring from the previous backup.. It shows that "installation complete". After that while rebooting the device just hangs in the same place. //SO CAN'T RESTORE FROM MY PREVIOUS BACKUP

I thought of copying the new rom in the device. I could not succeed. I tried adb command through my SDK. ADB is not listing my device. In all the forums it is mentioned that to enable the USB debugging from the phone. I cannot do this, because I cannot go into the device OS other than recovery mode.

I even tried some GUI stuff like Android commander / QtADB but every thing needs USB Enable from the OS Menu.

Finally I tried mounting disk from recovery mode. Whenever I mount the disk, Windows 7 is fixing the file system errors and bad sectors for a while and shows "no problems were found" and it is ready to use. Here something weird happens. I can copy the files in windows explorer and can see the files in the device thru explorer,

BUT when I unmount and browse from the recovery mode the files are not there. (may be the files are copied in cache) //SO I CAN'T COPY ANY FILE TO THE DEVICE.. ( May be here I am doing something silly. )

My phone is now unusable!

Any advice/tips is highly appreciated!

Cheers Kum

1 Answer 1



  • unlocked phone ('fastboot oem unlock' command)
  • installed Android SDK with accessible adb and fastboot executables (both are part of the SDK)
  • Cyanogenmod 7/9 or 10 image from get.cm (or whatever ROM you want)
  • Nexus S CWM recovery image from clockworkmod.com


  1. Flash the CWM recovery image:
    Switch off your Nexus S, press volume up & power to enter fastboot mode
    Command to flash: fastboot flash recovery recovery-clockwork-
  2. Boot to recovery (e.g. via fastboot boot recovery-clockwork-
  3. Enter a shell into the running CWM: adb shell, from there mount a tmpfs file system (used just for the update): mount -t tmpfs none /sdcard (This circumvents the sdcard completely, you don't need to format anything)
  4. Push the ROM image to the tmpfs (adb push cm-10-20120827-NIGHTLY-crespo.zip /sdcard/)
  5. Install this via CWM (the regular way)
  6. Follow the remaining usual steps (GApps, wipe, etc.)
  • Hi @ce4 Thank you for the quick response. All prerequisites are ready and in place. As per Step 1, I entered in to fastboot mode (with Lock State - UNLOCKED which is fine..) The command fastboot flash recovery recovery-clockwork- shows < waiting for device > adb devices didn't show any device. I selected recovery from fastboot mode, List of devices attached 3530CF39E0F800EC recovery Still it is waiting for device. Am I doing any thing wrong here? Thanks in advance Kumaran
    – Kumaran
    Aug 30, 2012 at 21:34
  • Finally I bypassed Step 1 and 2 and tried Step 3 I was happy during this step, because the pushed file was visible in the recovery mode. Then I installed it and rebooted.. Now it is hanging with Google logo and unlock image. (Previous to the Colourful CROSS image)
    – Kumaran
    Aug 30, 2012 at 21:43
  • Bypassing step1+2 will not work, the incl. recovery doesn't allow flashing I think. fastboot and adb need access rights to the phone via USB (start either as root or add some udev rules). You then can flash the CWM recovery image. You should see something like this). This post shows the output of both unlock and flash commands (for the Nexus 7 here). Just ask again if you need more help and please share your findings once you're done :-)
    – ce4
    Aug 31, 2012 at 7:23
  • Hi @ce4 Initially I tried in Windows 7. Today I used Ubuntu for ensuring root access. Then I followed these steps and installed the zip and wiped dalvik, cache etc. One thing I did was, I reinstalled the same zip again..(because wasn't sure about the order of wipe and install) and rebooted. This stage I was very happy.. But again it strucks in the same place.. Any advice?
    – Kumaran
    Sep 1, 2012 at 21:47
  • Any progress since your last status report? We'd better meet in chat maybe...
    – ce4
    Sep 9, 2012 at 14:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .