I have a two-week-old Google/Asus Nexus 7 tablet, unrooted and otherwise standard.

Yesterday it ran out of charge a lot faster than it usually does, and wouldn't seem to recharge. When it finally ran completely out of juice it shut down.

Now when I turn it on, it gets stuck in an endless boot loop. I contacted Google's support and they're looking to send out a new item. However if I go that road, I'll lose the data on there.

Has anyone experienced this issue? Is there anything else I could try? Thanks!


4 Answers 4


This answer is only really helpful for unlocked tablets.. Look after this paragraph if that is already the case. Otherwise read on.

"fastboot oem unlock" also does a factory reset, you need to have it unlocked before you need it, alas. This is both good for privacy and bad for recovery from half-bricked devices... The factory reset does In fact a secure erase which nullifies all your data.

According to Android: Building for devices:

$ fastboot oem unlock The procedure must be confirmed on-screen, and deletes the user data for privacy reasons. It only needs to be run once.

$ fastboot boot recovery-clockwork- 
downloading 'boot.img'...
FAILED (remote: Bootloader is locked.)
finished. total time: 0.020s
$ fastboot oem unlock
(bootloader) erasing userdata...
(bootloader) erasing userdata done
(bootloader) erasing cache...
(bootloader) erasing cache done
(bootloader) unlocking...
(bootloader) Bootloader is unlocked now.
OKAY [ 12.704s]
finished. total time: 12.704s
$ fastboot flash recovery recovery-clockwork- 
sending 'recovery' (6480 KB)...
OKAY [  0.785s]
writing 'recovery'...
OKAY [  0.225s]
finished. total time: 1.010s
# after that boot into the recovery (don't boot normal! it overwrites valuable data...)
$ adb shell cat /dev/block/platform/sdhci-tegra.3/by-name/UDA \| gzip -1 -c \| uuencode bla | uudecode -o - | gunzip -dc | bar > /media/qnap/backup/n7.data.formatted.img


You can boot a temporary custom recovery and create a backup of your device.

It should also be possible to wipe it afterwards and recover from your problem without having to send it back at all (provided it's not a hardware issue).


  • install the SDK (if not already done) and have working adb + fastboot executables ready
  • Download a CWM recovery image from here
  • unlock your Nexus 7's bootloader: fastboot oem unlock
    Here's how to enter the fastboot mode (the Nexus 7's codename is grouper): Press Power for a second, and press Volume Down when the bootloader logo appears
  • boot into a temporary CWM recovery: fastboot boot recovery-clockwork-
  • Create a nandroid/CWM backup from your broken installation (backup&restore->backup)
    • after the backup is complete, try to pull all data from your device:
      adb shell mount (should list something like /dev/block/mmcblk0p1 on /sdcard or so (not really sure however)
      adb pull /sdcard backup/ (replace /sdcard with the above noticed directory, this should extract all your data to backup/) check if everything is transmitted correctly)
    • you can buy TitaniumBackup+ProKey afterwards (it allows extracting data from Nandroid backups quite easily)
  • If that fails you can alternatively leech everything manually with adb:
    I assume you use Linux.


#list available devices:
adb shell ls /dev/block
adb shell cat /proc/partitions
#create images for each mtdblock 
#uuencoding is needed because the shell interferes with the stream (adds linefeeds or so):
adb shell cat /dev/block/mtdblockX \| uuencode foo | uudecode -o mtdblockX.img
adb shell cat /dev/block/mmcblkXXX \| uuencode foo | uudecode -o mmcblkXXX
#compare md5sums:
adb shell md5sum /dev/block/*
md5sum mtdblock* mmcblk*

# Look for reasonably sized images and what file system they are:
ls -lh mtdblock* mmcblk*
file mtdblock* mmcblk*
# You should be able to mount those images now (if you happen to use linux):
mount -t ext4 -oloop,ro mtdblockX /media/mtdblockX
# Now use some file-explorer to access your saved data
  • Final step:
    If you are really sure that you got all your data back, boot back into the CWM recovery (see step above) and issue a wipe data/factory reset command. Then reboot and re-setup your tablet (hopefully you don't have a hardware issue).
  • Optional step: relock your bootloader via fastboot oem lock
  • Hey there, thanks for this very detailed answer. Before I do this though, are any of these steps likely to invalidate any kind of warranty with Google. If it is a hardware issue, I wouldn't want to be left with a useless device and no recourse! Aug 27, 2012 at 17:15
  • If you have enabled 'adb' access (usb debugging) you could inspect your tablet before. However it's only possible to get the sdcard data, an 'adb backup' needs user confirmation via the UI (which is inaccessible). Let's take this to the chat?
    – ce4
    Aug 27, 2012 at 17:17
  • @DrewNoakes: Sorry, forgot to answer your real question: Hmm, I'm not sure if Google denies you the warranty. Google devices are made to be unlocked and played with and it's deliberately easy to unlock it (in comparison to other brands). I guess it's not a show stopper for warranty (you can relock it again). Plus you do not have to install the CWM permanently (it's temporarily booted in memory only; if you use 'fastboot boot ...').
    – ce4
    Aug 27, 2012 at 17:31
  • @DrewNoakes: Sorry, overlooked some real important part: unlocking wipes the device. Seems like there's little you can do to recover your data (see updated answer, there's a small possibility for file-carving though).
    – ce4
    Aug 28, 2012 at 14:25
  • Thanks @ce4. Your answer is really awesome, and when I get my new device I'll be sure to use the above to unlock it and have a play around with it. Although, knowing that if I were to lose the device it'd be harder for someone to get the data if it were locked is nice. Will have a think. Thanks again for a very educational answer. Aug 29, 2012 at 14:24

I just had a quite similar problem with my Galaxy Nexus (it didn't go past the Nexus X logo) and it seems it's not possible to make a backup with a locked bootloader and without root (at least not with Android 4.2).

I thought ce4's method could be a good try and so I unlocked the bootloader and then immediately booted clockwork recovery. Next, using adb shell I transfered the whole userdata partition (~14GB) and opening it in a hex editor I saw it's full of zero's 00. To be really sure I did a hexdump in adb shell and I saw the same (should have done this first). It's been completely wiped.

So unlocking the bootloader does do a full wipe of userdata and cache partitions and it's not possible to recover anything after that. Doing a quick search I wasn't able to find the exact file in android source where it's implemented (would be interesting...)

Sometimes Android is just too secure. I wish there would be way to backup data from fastboot (or Odin mode). With a locked bootloader it could even ask for a password or something. Anyway after this my phone did boot again and everything is working. Only my data has been lost forever...

To everyone I suggest to unlock the bootloader as soon as you get your droid and also make backups regularly...


I had the same auto startup loop zero battery problem after 6 months or so of flawless use. The tablet experienced zero battery. Upon plugging in the Asus, the power supply would start up, go to home screen, and display "shutting down" after 2 seconds. As it shut down, it would show a screen of "static noise" like an untuned analog tv. Then, say two minutes or so later, it would repeat without any intervention, and ad infinitum. Battery never goes over zero.

There is a thread here that is also about the same issue.

There is an albeit slightly hard to understand fix offered in the above thread, which started with "plug into pc". I tried to follow steps without plugging into PC, as I could see no particular reason why this would make a difference, without joy. I then plugged into PC USB. Large "battery charging" screen immediately displayed, and I'm currently just letting it charge (if it actually is). Very odd flaw. I imagine as the batteries get a little older, this may become a common experience for many.

I recommend checking the Android Central thread. I'll be replying there with my results.

_ just a quick update here (I did put full process I undertook on the other thread though) to say it all worked out well, and after leaving to charge from pc, the tablet finally started up normally again. Phew...


I know it is a late answer, but it might help out others.

This might seem ridiculous, but this is what was causing the bootlooping on my Nexus 7. My tablet arrived from Amazon, I took it out of the box, plugged it in to charge. Battery icon didnt show a charge. Started it up and it got to the Google and the lock, then would restart over and over. So I did some reading and came across this fix.

Some how the tablet got "jostled", in other words banged. the tape that holds the battery wasn't placed properly so it allowed the battery to shift ever so slightly causing the cable to pull apart from the connection. enough to make a bootloop.

now the fix

Pull the back cover off, peel the tape back off the top of the battery, GENTLY PULL OR TWIST the battery (there is double-sided tape underneath it) to realign it so the cable can be attached correctly. When finished put the tape back across the battery and close the case up.

This is just one possible cause of bootlooping, the other answers will also work depending on circumstances.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .