10

I am interested in purchasing the Game from Google Play Store, but when I try to purchase it using the buy Button in game menu it takes me to Play store and there I get a message "You already own this item", but when I click on details button in the message box the play store application crashes.

Now I don't know even if I own this or not. If I own it then why didn't I received this full version and if I do not own it then how I will be able to purchase it?

7
  • 1
    Which app has this problem? Some apps do their own transaction restoring on the first start (and don't support rebuying. I had that with an earlier version of pinball arcade some time ago). File a bug report for the app or clear the app data and restart with a working internet connection (leave droidwall if you use it disabled).
    – ce4
    Aug 29, 2012 at 20:18
  • 2
    Sometimes this happens when there is an error while completing the transaction. Can you do the following: Settings->Apps->All->Google Play Store press Clear data and Clear cache, then check if the issue is resolved? Aug 30, 2012 at 0:42
  • 1
    Thanks for your reponses The Game is "Rise of Glory", I tried to clear the cache and clear the Applications data (Play Sore and the Game) but the issue is not resolved. I am still receiving the same dialog i.e. "You already own this item", clicking on the detail crashes the play store application after a message "Play Store Stopped Unexpectedly ". Aug 30, 2012 at 3:48
  • 3
    Ok, This is a known issue and you can find the issue at support.google.com/googleplay/bin/… [#702829] Falsely receiving error: "You already own this item" Google Technical team is working on this and hopefully this issue will be resolved. Aug 31, 2012 at 7:58
  • 2
    Hmm the link to the issues doesn't work. If you got a working link, feel free to post it as answer to your own question.
    – Flow
    Oct 13, 2012 at 13:33

2 Answers 2

1

Summed up from the comments:

This was a known issue with Google Play, which meanwhile is resolved (read more on this Google support page, opening the "fixed/resolved" item, and there you see [#8849329] Falsely received error: "You already own this item", together with more details).

0

The best option that worked for me was to install the following app that will allow you to download the app again "Purchased Apps (Reinstall your paid apps)" https://play.google.com/store/apps/details?id=com.azefsw.purchasedapps&hl=en

1
  • This did not work for me. Continues to say ERROR you already own this item I own it but can't download it. Thing is I did a factory data reset and list it that way. Apr 11, 2021 at 20:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .