I've inherited my wife's Android phone (GT540) when she got a newer, shining one :-)

We think to have factory reset it (via the privacy option), and in fact it has finally stopped to refer to her account and all the pics are gone. But I keep getting a warning message, about inconsistent UIDs and the need of wiping the data partition to be sure.

I can click on the only button "I am feeling lucky" to continue, without noticing particular issues.

Obviously, as per Murphy, the message is not popping up right now, so I can't copy it verbatim :-) Will edit the question when it comes out again.


The precise message is:

System UIDs inconsistent

UIDs on the system are inconsistent, you need to wipe your data partition or your device will be unstable.

And it is followed by the unexpected crash of the Market application (processocom.android.vending).


  1. what is happening? what data partition is actually worrying it? Wasn't the reset "hard enough"?
  2. what could happen, what UIDs is it referring to?
  3. how can I fix it?

I have a new SD card, which is as far as I can tell empty. I would have liked to format it before using it, but the option is not available: I can only unmount it. Is this (missed) formatting the required wiping to reset the UIDs? Or is it a completely different thing, which I will search/ask in a later question?

Being new to the Android system I don't know if any other info are missing. The kernel is 2.6.29 (but I would be surprised if such basic matters were strongly dependent on the precise kernel version....). Just in case the firmware of the phone is 2.1-update1.


I have asked my wife and she actually did the factory reset suggested. Just in case I did it again, and we still get the error. What now?

3 Answers 3


I found another solution:

Have a look at /data/system/uiderrors.txt. There you will find the apps that are responsible for the trouble. You can delete them (manualy if necessary) to fix the issue. Reinstalling the apps brings the error back, though.


Titanium Backup users can also go to the batch actions and select manipulate data > remove orphaned files.

As user48823 mentioned, you can also find the apps in /data/system/uiderrors.txt using a root-capable file explorer, but basically Titanium will do this for you, if you select the action I wrote above.

Just fixed it this way on my OnePlus One (Bacon).

  • worked very well for me, thanks! :) I think the problem happened because of a corrupted titanium restore anyway! Commented Mar 3, 2016 at 5:36
  1. Usually a hard-reset should be sufficient. But as I don't know how you performed it: It cannot hurt to repeat it. There's a "factory reset" option in your menus (usually in the "privacy" section). What this does is rawly explained by its name: Reset everything to the state of delivery. It purges the /data partition -- which is, all user data: Installed apps (except those "in the ROM", which came pre-installed) along with all apps data and settings, plus wipe the cache -- then reboot. The next startup will take a bit longer, as Android needs to rebuild the Dalvik Cache (which basically contains device-optimized versions of your apps, simply spoken). So after that, everything should be clean -- and you need to configure everything as if you just got a fresh phone.
  2. I don't know which UUIDs it's referring to -- without the exact error message this is hard to tell. But as said, the factory reset should fix this.
  3. By 1. plus, to be absolutely sure, a clean and empty sd card. To make sure the latter is really clean and empty, you can use a card reader to attach it directly to your computer, and check its contents there. Formatting should not really be necessary -- just make sure there are no files left, especially also no "hidden ones".

Following methods are available to initiate a "factory reset" aka "factory wipe":

  • the corresponding item in setup -> privacy
  • a "call to the magic number *2767*3855#"
  • Turn ON your phone. Press both VOLUME UP + HOME + SEARCH buttons for 5 sec. (this last item is taken from hard-reset.com)
  • Thanks, i will ask her about the precise format procedure she used. I have added the message as soon as it popped up again. Is it clear enough now to understand what's going on?
    – Francesco
    Commented Aug 30, 2012 at 8:21
  • Yepp, quite clear. Following my "step-1-description" should solve this, as a factory reset includes exactly that (wipe /data and /cache). Essentially it does a little more than required -- but with /data wiped you either need to "start from the scratch", so the cleaner the better :)
    – Izzy
    Commented Aug 30, 2012 at 8:25
  • Unfortunately it didn't appear to solve. Is there a way to manually wipe the data partition? Which by the way appears to be empty (I am using astro, I have a /data folder which is shown to be empty. I also have a /sdcard/data folder, which contains an almost empty folder /sdcard/data/colornote/backup with two files within).
    – Francesco
    Commented Aug 30, 2012 at 14:54
  • use fastboot to format the /data partition, that is, provided your computer can recognize the handset in fastboot mode.
    – t0mm13b
    Commented Aug 30, 2012 at 15:26
  • 1
    In this case I'm out; aside from flashing, it might be time for SYLoV (See Your Local Vendor). For sure if you still have warranty -- they might give you a newer device as replacement, if you can clearly show them the factory reset doesn't do what it's supposed to. Maybe not that "shining one" -- but still...
    – Izzy
    Commented Aug 30, 2012 at 15:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .