I have a new HTC desire. After 3 days of use it started mounting the SD card in read only mode. I couldn't mount it in read-write mode until I formated the card in another phone.

I read somewhere on the HTC forums that this may be caused by plugging the phone in a Mac. But this doesn't make any sense to me. I did plug the phone in a Mac the first time, but this didn't start happening after that. It started happening after I've plugged the phone in a Windows 7 pc. I've never used the phone plugged in a computer in sync mode, it was either used as a mass storage device or in charge only mode (which was the case before this problem ocured). Of all the portable devices I've used that could be used as a mass storage there's never been a problem if I've used them with OS X, Linux or Windows. So I don't find the OS X explanation satisfactory. From what I know all operating systems will handle mass storage devices in the same way more or less especially if it's a FAT filesystem.

Has anyone else experienced this problem?

  • What software version do you have? When I first had my Desire I occasionally found my SD Card was read-only, though this was fixed with a reboot and did not require reformatting. At some point, one update or another must have fixed the issue as I haven't seen it for some time - certainly not since updating to Froyo/2.2. – FoleyIsGood Nov 19 '10 at 13:45
  • I had a lot of SD card issues with my Desire. Sometimes read only but more often failed to mount it completely, and I've heard a few similar tales. I ended up having it replaced on warranty (because it was overheating and restarting) and have had no SD card problems at all with the replacement. – misterben Nov 24 '10 at 20:24
  • @FoleyIsGood It's Froyo. I haven't had that problem in the past few weeks but I haven't connected it to a computer via USB in that time either. – Vasil Nov 30 '10 at 19:57

I had the same problem with stock 2.1 ROM.

After the OTA update to 2.2, the problem vanished.

|improve this answer|||||

I have HTC Desire too. I don't know what causes this problem, but I fixed it by mounting it on a Windows computer and checking the filesystem on the card. I tried it on a Mac first, but OSX Disk Utility couldn't fix the problems it found.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.