I'm using a custom ROM of CyanogenMod 7 (Android 2.3.5) on ZTE Racer. The ROM came with some default system apps like Gmail, Google Translate, Youtube and Adobe Reader. The old version of these apps are kept in internal storage even if you update them, so to save space I uninstalled the updates and them removed them using Root Manager.

The problem is that when I installed the updated versions from Market, they force close during opening (I found out later that Google Translate force close only when trying to translate something).

I had backed up everything before uninstall, and I noticed that if I install the backed up version manually and then update it through Google Play, they work fine. Checking the storage space left, I can say that the old versions were this way deleted, so I suppose the result should be the same.

Since I did not notice that Google Translate wasn't working, I deleted the backed up apk file, so I can't put it to work again.

My question is: anyone knows why does this happen? And if so, how could I make the updated version of Google Translate to work now that I do not have the old default apk anymore?

Edit: I tried installed again to trace the exact error message and it is now working, though I have done anything explicitly.

  • Which device? Which system apps did you remove? I would recommend to delete parts of the gapps package, cause it could lead to the kind of problems.
    – Flow
    Sep 1, 2012 at 11:40
  • 1
    First step would be to look at the Android log after a fc has happened.
    – Flow
    Sep 1, 2012 at 12:27
  • Thanks for the link, I'll consider using that next time something crashes, though I remember seeing the details of the "report" and it was a NullPointerException. I have tried one last time to install it directly from Google Play and it's now working, I'm not sure why (I had already rebooted after uninstall it). Sep 1, 2012 at 18:48

2 Answers 2


I cannot say for all apps you listed -- but for some, the following applies:

Some system apps (as e.g. the market/playstore app) have to be present in /system in order to work. For the Playstore app, the reason is: The permission to install other "packages" is only granted if one of the following two conditions is met:

  • it is signed with the same certificate as the system (ROM) itself -- which does NOT apply in your case, due to the custom ROM used
  • it is installed as "system app" (i.e. below /system) -- which did no longer apply in your case, since you uninstalled the app from there

Expecting the pre-conditions given, developers might have forgotten to include a check and implement appropriate exception handling -- which then may lead to the described force-close.

Similar constellations might apply to other apps/packages as well -- though I'm not sure what should make the Google Translate app so special (maybe it has some special hooks I missed).

You could try to find out by following Roxan's advice, to integrate the app as "system app" again using e.g. Titanium backup, and see if it still force-closes.


Instead of doing this manually, use Titanium Backup Pro.

It allows you to integrate updates to ROM for all system apps.

So after installing this, long press your desired app and choose the option integrate update.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .