My Snow Leopard Mac doesn't recognize my Samsung Galaxy S2 for file transfer over USB, and it's starting to drive me nuts.

I've tried the following:

Connect Storage to PC

Settings > Wireless and Networks > USB Utilities > Connect Storage to PC

I've tried this several times on my phone, following the procedure stating that I should only connect after the phone asks me to, but it does not work.

There is no "attach-button" in the pull down menu, like some claim there should be. Yet it seems that the phone notices that the USB-cable is connected. However OS X does not. No external storage pops up in Finder. I've also tried waiting for several minutes as I know this sometimes can take a while, but to no avail.

USB Debugging

Settings > Applications > Development > USB debugging

When set to on, nothing happens. When set to off, nothing happens either. (It is automatically shut off when using Connect Storage to PC.)

Android File Transfer

I've also downloaded Android File Transfer, and while the phone finally recognized something by stating MTP-Connected in the pull-down menu, nothing happens in OS X, nor the Android File Transfer program itself. It just continues to demand that I attach the USB cable.

I've also tried it in conjunction with both USB Debugging on and off, to no avail. When it's on, the phone doesn't detect any MTP. When it's off, the phone detects MTP. Either way, it seems that OS X doesn't detect jack...

USB Prober

The USB Prober on my Mac does detect something when I connect the USB to my phone, but I do not understand the message after the timestamp, that is: [1] AppleUSBOHCI[0x56f9800]::SuspendUSBBus Processing WDH before suspending.

USB Cable

I've tried with two different brand new cables. Made no difference.

Please do not post answers suggesting the use of Kies, Bluetooth, Wireless, and the like. I want my phone to work over USB for a reason (speed and convenience).

  • It sounds like a driver issue. I'm a Windows user, but I would first look for the specific device drivers for your phone. You may still have to install Kies just for the drivers: samsung.com/uk/support/model/GT-I9100LKAXEU-downloads Additionally, you can try installing pda.net which has drivers for most Android devices bundled (you can uninstall the app after you get the drivers from it): junefabrics.com/android/download.php Not posting as an answer because I'm not sure how applicable this is to a Mac
    – Bryan Denny
    Sep 4, 2012 at 14:56
  • 1
    I don't think pda.net will really help on a Mac. The issue is that it doesn't support MTP natively, which drivers aren't really relevant for. Unfortunately, even Google's support page recommends using Android File Transfer, so if that's not working then options may be limited. Sep 4, 2012 at 15:14

1 Answer 1


tested on mac osx snow leopard and Mountain Lion: with your device unplugged go to settings->developer options disable usb debugging;

Go to Settings, in wireless and network section, go to "more"->usb utilities Tap on "Connect storage to PC". Plug in your device to your mac and the tap on "Turn on USB storage" and OK. You should see your device just like an USB pen.

  • Thank you! This didn't work before. Must be an update.
    – Kebman
    Dec 22, 2012 at 16:32
  • Aaaand suddenly it doesn't work anymore. It only worked that one time it seems. STRANGE!
    – Kebman
    Jan 14, 2013 at 22:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .