I bought one of these simple cheap Chinese no-name tablets: HDMI, Bluetooth, HD display, dual-core CPU. Unfortunately, it came without official Google apps such as Market and Gmail. I tried different ways to install these apps. Every time I got a Force Close error.

I'm using Ubuntu as my workstation and looked with adb for the device. Found one, good! The command lsusb gives me

Bus 001 Device 031: ID 18d1:4e22 Google Inc. Nexus S (debug)

I've tried obtaining root access on this device, without any success. Information about the hardware is attached as a screenshot, made with Quadrant Benchmark.

screen shot

I have tried these tools:

  • SuperOneClick
  • UniversalAndroot
  • EasyRootICS

BusyBox is installed but without su. Cannot remount /system, because its not permitted.

Cannot login with adb root, it fails with the following message

> adbd cannot run as root in production builds
  • You can try xray.io/dl for additional exploits (it's a security tool by a well-known researcher (J.Oberheide from DuoSecurity). It checks for common vulnerabilities. Also: Do you have a means to boot into recovery and/or fastboot mode? The recovery might come with root access and fastboot boot boot.img gives you the ability to start a custom boot image that can give you root (if the bootloader is unlocked). Generally, those cheap tablets have weak security.
    – ce4
    Commented Nov 29, 2012 at 16:11

3 Answers 3


If you don't know what device you have, it's hard to get any assistance.

Without any warranties of success, and without assuming any responsability by what may happen to your device, I can suggest that you visit UnlockRoot, known to work with tons of devices, may became a solution for yours.

The process is done with three steps:

  1. Your device must be in USB Debugging mode. Turn it on, go to Settings-> Applications-> Development and check the box.(Look Here
  2. Connect your device to your PC, Run UnlockRoot.exe.
  3. Click "Unlock Root", enjoy!

And it's reported to work quiet well, see last entry labeled "What are the Risks of Rooting?".

The FAQ section is also quiet useful.

Read the documentation from the website and proceed at your own risk.

  • This will not work with ICS, as it says in its FAQ.
    – Liam W
    Commented Nov 29, 2012 at 15:44

You will really struggle finding a way to root a tablet running ICS, especially a 'no brand' one.

I have had the same issue with an Arnova Gbook.

Unfortunately, the answer to your question is that it would be very difficult, and maybe even impossible, unless a new ICS root exploit comes out, as Google patched the main one in Android 4.0.


try using VROOT, i've purchased a unbanded phone, (actually locally branded). Using VROOT i was able to get it rooted, now i am looking for a method to install CWM Recovery, and you just gave me a idea.. Thanks and i hope it works for you too !!

  • Please add a link to this app; I can't find it on the Google Play app store. Thanks!
    – Niall C.
    Commented Jan 2, 2015 at 21:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .