I bought a 64GB SD card for my Galaxy S3, and it worked perfectly. Today I turned on device encryption (worked fine) then I turned on SD card encryption. Since then I am stuck with the phone reporting that the SD card is blank or has an unsupported file system. Android gives me the option to format. The screen displays it is erasing, but then nothing happens.

I have tried removing the SD card and turning the phone on and off again. I have manually formatted the card using Windows 7 (ExFAT file system). I am able to read and write files to the card on the computer but the phone refuses to acknowledge a mountable SD Card.

I have also tried turning off the SD card encryption.

Any ideas on a fix?


3 Answers 3


I had the same problem...new 32gig sd card works just fine with Windows, but in my Samsung S2,S3, and EVO it says damaged, or unsupported, etc. I then read on another droid forum about this issue, and here is the easy fix:

Put your sd card into a usb reader for mem cards etc. You will notice that your card reader has a drive number like G:, or H:, etc. Make a shortcut on your windows desktop and make the shortcut location as (cmd). You may remember that cmd is the DOS-box command line prompt. Now your shortcut to cmd is on your desktop. Right click that shortcut and select "run as administrator". Now at the DOS prompt type

chkdsk <drive letter of the sd>: /r

Let it run through it's checks, etc. Once done just pop your sd card back into your phone and enjoy!


You can download the tool MiniTool Partition Wizard Home Edition and make a fresh format of the memory card. Here is a guide you can follow to complete this task. N.B just ignore the steps about ext2 etc. and format using your desired File System. Ensure that you create as Primary.

  • Thanks Joel, I managed to workaround the issue. To get Android to recognise the card I had to turn off password unlock! (Went back to pattern). After which I was able to format and use the card again. I was able to reproduce the issue again. So it looks like there is a some defect with SD card encryption? Possible limited to the S3 and/or 64GB SD Card types... For now I will just live with Device encryption only.
    – James
    Commented Sep 10, 2012 at 18:29
  • alright man glad your card still works.
    – Joel Dean
    Commented Sep 10, 2012 at 21:18

For reference.

I was able to fix the issue by turning off password unlock in security. I went back to Pattern unlock.

I was able to reproduce the the issue again. As soon as I enabled SD Encryption the Card becomes "Blank" and Android refused to use it, Format does nothing. Card is not mountable

So it seems there is a issue possibly limited to the S3/64GB Card with SD Card Encryption.

I have not been able to find any reference to this issue else where. Its not a show stopper so I will continue without SD Encryption.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .