I tried to upgrade my firmware on my Samsung Galaxy S using Kies

The Firmware upgrade appears to have gotten stuck.

Kies says

Upgradeing firmware... Do not disconnect a mobile device from the PC during upgrade process Progress Bar has "Upgrade is in progress.." and is stack at about 1/3

The phone screen shows a green triangle with Downloading... below it and "Do not turn off Target!!! at the bottom.

It has been this way for about an hour.

What should I do?

Should I unplug my phone? Should I keep on waiting?

I really don't want to end up with a brick.

  • in 30 minutes I am going to unplug it, unless someone has provided an answer before then.
    – trampster
    Nov 17, 2010 at 0:34
  • 1
    I've noticed that Kies will often display pop-up windows behind other applications and just wait for you to notice them. Double check that it hasn't done it in this case.
    – Niall C.
    Nov 17, 2010 at 1:10
  • @Niall I couldn't find any hidden pop-up windows
    – trampster
    Nov 17, 2010 at 1:44
  • OK, sorry I couldn't help. Glad to see it recovered OK.
    – Niall C.
    Nov 17, 2010 at 1:48
  • An hour was definitely too long, I'm sure the entire process was about half that when I upgraded (and most of that time was spent in the download from Samsung's servers).
    – GAThrawn
    Nov 17, 2010 at 13:20

8 Answers 8


I disconnected the cable

Kies popped up an error message which said, the upgrade failed and offered to try to recover for me.

By following the instructions on screen I was able to recover my device.

  • 1
    What did the instructions say?
    – Flow
    Sep 12, 2011 at 7:12

I had the exact experience tramster had. I didn't wait nearly as long however. In all I tried about 5 times. My best theory is a loss of connection through a flaky USB connection. I switched from the front USB port on my computer to the back one.

Eventually it crashed during an emergency reset. I thought I was in trouble. I the emergency reset again, which completed. I was shocked to see that it didn't revert to the previous version, but installed the update instead! bonus.

Another Kies problem; long file extensions. Remove or rename all files with a period (.) followed by more than 16 characters. This is particularly common with imported music files. "Dance by Dr. know featuring RX-man" for example has what the device sees as a very long extension. Remove the Dr. and you are good to go.

Connect in USB mode on the computer and do a search for *.?????????????????* to find all the offending files. I found.one.file.that.had lots of periods. That won't be a problem though because none of them are longer than 16 characters.


I did faced the same problem, but resolved successfully in second attempt.

  • See if you have any USB autorun restrictions for USB devices, I do have USB Security software Installed, which disables autorun feature for all external devices connects to PC either USB or any optical drive.

  • Try lengthened the display timeout for your mobile device (I set it to 30 minutes) to ensure your device do not got disconnected and system re-connects it during upgrade process.

There was a failure for my first upgrade attempt, I waited for around 40 minutes (after firmware download completed from Samsung server), then I removed the USB cable and Kies asked whether I want to stop upgrade process or not? I chose yes and closed the program. After that I restarted my device and I saw an empty battery and the device went off, I restarted the device after connecting the USB cable and now I saw a Green battery with small dots below showing progress, simultaneously I saw a window showing me to enable emergency repair for firmware, I followed steps and that wasn't successful, but my device was working perfect after that process.

I followed the first 2 steps mentioned above and then ran the upgrade process again and it was a smooth process upgrading the firmware successfully.



I had faced same problem on Windows 7. Then I tried updating firmware from Windows XP and it worked without any problem.


If you are encountering issues or lack of update make sure that your Kies window is maximized before proceeding with the update. The hidden popups do happen and you will otherwise not be able to find them. Once the window is maximized the popups get focus and you should be able to proceed with the update.


Galaxy S's are nearly unbrickable, I've never heard of one being bricked apart from the (very few) hardware locked ones. Firmware updates have quite often failed for me and worked the next time I tried. So I would go ahead and unplug it and retry. The likely worst case is that you'll need to use Odin.


Well, for me it started the download process, and then Kies said it could not recognise the phone, and disconnected it - but the phone (A Galaxy S) was still in the "downloading, do not turn off" screen. No other recovery other than to restart with battery reset. Fingers crossed...

Well it booted at least.

On thing to consider would be to force Kies to run in compatibility mode, given that it is a 2013 program - to Win 7, or even Win XP (above poster gives that clue). I am trying this on a Win 8.1 rig


I had to open task manager and end all processes like skype, icloud, last.fm, spotify. once there was a decent amount of cpu and memory available, the program went from 69% complete, to 85% to 100% within five mins of when i opened task manager.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .