I have a Huawei u8160 running Cyanogenmod 7.2 .

I've recently been testing things on my recently activated OTG I've tried to connect a USB Portable HDD, However when I connect the HDD the LED flashes like it's reading/writing , dmesg notices it :

 <6>[12, khubd] [10776.834610] usb 1-1.4: new full speed USB device using msm_hsusb_host and address 40

 <6>[12, khubd] [10777.015514] usb 1-1.4: not running at top speed;
 connect to a high speed hub

 <7>[12, khubd] [10777.018517] usb 1-1.4: default language 0x0409

 <7>[12, khubd] [10777.021505] usb 1-1.4: udev 40, busnum 1, minor = 39

 <6>[12, khubd] [10777.021544] usb 1-1.4: New USB device found,
 idVendor=174c, idProduct=5106

 <6>[12, khubd] [10777.021567] usb 1-1.4: New USB device strings:
 Mfr=2, Product=3, SerialNumber=1

 <6>[12, khubd] [10777.021589] usb 1-1.4: Product: StoreJet Transcend

 <6>[12, khubd] [10777.021607] usb 1-1.4: Manufacturer: StoreJet

 <6>[12, khubd] [10777.021624] usb 1-1.4: SerialNumber:     

 <7>[12, khubd] [10777.022149] usb 1-1.4: uevent


that is what dmesg says directly after connecting.

and when I write lsusb on terminal emulator it returns :

 Bus 001 Device 001: ID 1d6b:0002

 Bus 001 Device 041: ID 058f:9254

 Bus 001 Device 042: ID 174c:5106

one of them is always there,and another one is the USB Hub ,and another is the USB HDD

I already successfully mounted an NTFS Flash Drive (Fromatted using Minitool partition wizard,mounted using Paragon NTFS&HFS+) then the problem isn't the File System


Error when trying to mount USB flash drive that is NTFS formatted :

mount: mounting /dev/block/uba1 on /sdcard/data failed: Invalid argument

Error when trying to mount NTFS formatted portable HDD :

mount: mounting /dev/block/uba on /sdcard/data failed: No medium found

that means that the error in the HDD isn't with the NTFS file system.

EDIT #2:

I've tried this method but when I try to mount it it gives me this error :

Failed to mount '/dev/block/uba': No medium found
  • 1
    the kernel may not have the NTFS filesystem driver compiled in to the CM version.
    – t0mm13b
    Commented Sep 12, 2012 at 13:53
  • @t0mm13b "I already successfully mounted an NTFS Flash Drive then the problem isn't the File System" and I already said that ,please read to the end Commented Sep 12, 2012 at 13:54
  • Have you actually confirmed there is a NTFS Driver in place in the kernel?
    – t0mm13b
    Commented Sep 12, 2012 at 13:57
  • NTFS Flash Drive? How did you format a "thumb drive" as NTFS? windows will only flash those sort of drives as FAT32 Commented Sep 12, 2012 at 13:57
  • 1
    @t0mm13b the problem here isn't NTFS I've successfully mounted NTFS that's not a problem Commented Sep 12, 2012 at 14:00

2 Answers 2


CyanogenMod does not support NTFS. You would have to compile your own kernel module for the CM Kernel in order to mount NTFS.

Edit for you comment about the Paragon App: using an app like that is different then actually mounting it in android. If it doesn't work with your drive, it is an issue with the application, not CM7.

The app is implementing the NTFS protocol within the application. If it fails to mount, then there is a problem with the application. There are lots of reviews for the app that say "did not work with X", so it seems you are not the only one that has issues.

Your only option is to contact the developer and send them the problem you have, so they can fix it.

In response for your Edit #1 and Edit #2

You will not be able to mount with mount android doesn't have a kernel module that supports NTFS. As I said above, the reason that you can mount it within the app is because the app developer implemented the NTFS protocol in their application. Invalid argument means that the filesystem type you are trying to mount is not supported by mount. No medium found means that it does not see that dev block or cannot access it.

It also sounds like the problem may be that the HDD you are trying to mount requires different drivers to communicate with the HDD controller. Sounds like you are able to get flash drives to work, and that is because they are probably using a "standard" communication, while the HDD could be using something non-standard, or has a different chipset and is not supported by default by the kernel.

  • it doesn't fail to mount it ,it doesn't see it at all Commented Sep 12, 2012 at 14:16
  • and people mention that too. it is still an issue with the application. Android does not have NTFS support. Commented Sep 12, 2012 at 14:18
  • it worked with the thumb drive ,why wouldn't it work with hdd? Commented Sep 12, 2012 at 16:58
  • the drive could require different drivers. could use a different protocol, might be larger then the app actually supports. There are many things that could answer this, but since the only one that would know this is the developer of the app you are using, any answer would basically be speculation. Commented Sep 12, 2012 at 18:47

Try to use ntfs-3g. Over it you add device, then you need mount you device to some mount point. This util simply compiled for arm.

  • but I can't find fuse.ko for my device Commented Sep 16, 2012 at 19:48
  • found out it was already compiled in cm 7.2 , my bad. Commented Sep 16, 2012 at 21:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .