0

Possible Duplicate:
SD card partitioning? why? how?

I am trying to partition my sd card on my Samsung Galaxy Ace because I want to extend my memory using the app link2sd but I have some problems doing it.

I am following this procedure which I first tried on my HTC Desire with perfect results:

open gparted
search for the filesystem I am interested in
make a first fat32 partition of 3GB for the SD
make a second ext3 partition of 800MB to extend internal memory and use link2sd    
apply

At this point I get an error, gparted is unable to do the first partition. If I try to change the orders/types of partition the error is always the same. Now I have a not allocated SD which is working to host data but I'd like it to work as an extension of my internal memory.

What I'm doing wrong? How can I solve it?

Thanks

marked as duplicate by Izzy, R R, Zuul, ce4, Chahk Sep 22 '12 at 20:20

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • You didn't provide the error message, so I can only take a good guess: As it already happened at the first partition: Did you first delete the (only) partition on the card? Otherwise: No free space left to create any (new) partition ;) – Izzy Sep 16 '12 at 15:26
  • I am sorry you are right. This is a link to a folder where there is the file saved by gparted wuth the errors: dropbox.com/sh/nea2gor32pwqjcl/nOXnzD67Fc Unfortunately it is formatted in html so not very very easy to read. – Luigi Tiburzi Sep 16 '12 at 15:58
  • I think I first deleted the only partition on the sd card – Luigi Tiburzi Sep 16 '12 at 16:02
  • Yes, you did -- as the "create partition" in your log stated "Success" (btw: Hard to read an HTML file in dropbox -- plain text would have been easier). The error occurs when creating the file system; looks like another process still accesses the partition ("Device or resource busy"). Would be helpful if you explain the steps you performed. – Izzy Sep 16 '12 at 17:17
  • Yes sorry it's quite hard. How could I share the file? By the way, it is pretty difficult to remember the exact steps I performed because I got quite nervous and started to try all the possible combinations between orders and types of partitions. Probably I firstly deleted the existent partition and tried a start over, obviously without success. I can't understand the error though, if the SD card is empty, how can't a new partition work? – Luigi Tiburzi Sep 16 '12 at 21:47