Initially I thought this was a problem with Google Play / Apollo, but I realize now that when I plug in my phone via USB, I can't see any of the many, many folders and files present on /sdcard that I could see previously.

If I copy a "new" mp3 onto my Galaxy Nexus, it's recognized just fine by both Google Play and Apollo. However, none of my old mp3s are recognized. They were placed in /sdcard/Music, a folder that I cannot see when I plug in my phone, only from the file manager running on the phone. The issue persists if I move an "old" mp3 from my music folder out into the sdcard root, it's still not recognized. This makes me think this might be permission related, but the file manager says that all files are readable and writable.

I've tried running "fix permissions" in both ROM manager and the CWM recovery, but it makes no difference. Any idea what has happened, and how to fix it so that I can use all my old files again? :)

edit If it's any help, I just ran ls -al in a terminal emulator and I can't see any difference at all between folders I can and cannot see. Example: I can see /sdcard/media just fine, because I created that folder from Explorer in Windows. Music in that directory works. I cannot see /sdcard/music. Here's the permissions:

drwxrwxr-x root sdcard_rw 2012-09-18 media
drwxrwxr-x root sdcard_rw 2012-09-16 music

This is a bit confusing.

edit2 When I try pulling and pushing a file with adb like so:

adb pull file.tar
adb push file.tar file2.tar

I get

failed to copy 'file.tar' to 'file2.tar': Read-only file system

As bk201doesntexist on the XDA forums pointed out, this is because you have to use an absolute path. However, when I do adb push file.tar /sdcard/file.tar the file gets transferred, shows up when i run ls, but it's invisible in the "Galaxy Nexus" unit in My Computer in Windows.

tl;dr When I push files with adb push they get transferred but don't show up in the "Galaxy Nexus" unit in My Computer. "Old" files from before ROM-switching do not show up. New files that I put in now work fine.

  • Can you check to see if there's a file called .nomedia inside either the /sdcard/Music directory or on the root of the card? An older version of CWM used to mistakenly create that file, which would prevent media from being properly scanned.
    – Chahk
    Commented Sep 18, 2012 at 12:49
  • I've checked, and there's not. Remember that a lot of other folders also have "disappeared", such as DCIM, Download etc. (these I can also see just fine from my phone)
    – pzkpfw
    Commented Sep 18, 2012 at 12:51
  • Also, try SDrescan app to manually launch the media scanner process to see if it picks up older media.
    – Chahk
    Commented Sep 18, 2012 at 12:51
  • What happens if you adb pull an "old" mp3 to your PC and then adb push it back to either /sdcard/Music or /sdcard/media?
    – Chahk
    Commented Sep 18, 2012 at 12:54
  • My initial adb pull/push test was incorrect, updated with new info now.
    – pzkpfw
    Commented Sep 18, 2012 at 15:33

3 Answers 3


A few things that will do you good before you start resolving this issue.

  • This issue has been around since CM 9 and has been inherited by CM 10.
  • While ROM Manager (and not CWM) was the culprit some time ago, the issue has since been resolved by them.
  • The .nomedia file you are looking for should be inside /sdcard/Android/data. It may not be there but can't hurt to look for it.
  • Have a good file manager with root access installed and have it set up to search for hidden files. I recommend Root Explorer.

Okay, enough info. Let's get cracking. Follow this and let me know if it resolved your issue. Follow everything to the T. Do not leapfrog over steps or try to do anything else before you have gone through the entire process. All the best!

  • I don't understand. How can a .nomedia file in directory X cause directory Y to not show up? Also, with root mode on and "show hidden files" on, ES File Explorer reports no files matching when I search for .nomedia and *nomedia*. I'd also like to report that when I snap a picture, they show up as a black rectangle in Gallery, as opposed to not at all as the old files do. I'm sorry, but I don't see how your answer applies to my problem.
    – pzkpfw
    Commented Sep 18, 2012 at 17:09
  • I don't know either but this did solve my problem which is exactly your problem except with a CM 10-based ROM called Paranoid Android on two separate devices, namely, the HTC Desire HD and the Galaxy Nexus GSM (codenamed maguro). Did you give it a shot anyway?
    – I-O
    Commented Sep 19, 2012 at 7:05
  • I did try to look for "nomedia"-files as I said, but didn't find any on my SD card whatsoever. No idea why, but reformatting the sdcard worked anyway so I'm satisfied, I needed to clean it up anyway.
    – pzkpfw
    Commented Sep 20, 2012 at 8:15
  • Cool. Glad it worked out for you. :)
    – I-O
    Commented Sep 21, 2012 at 4:49

As a final resort, I tried doing a full wipe and reinstalling CM10 M1 completely, without restoring any settings or apps from any old installations. The issue still persists! Any files created with my now "old" CM10 installation no longer appear, even when they are moved within a folder where other "new" files are shown and working. Switching back to AOKP also did not solve the issue, so the issue does not only persist over reinstalls of CM but also across ROMs.

What finally solved this issue for me was reformatting my /sdcard partition with the newest version of CWM Recovery. This might not be a very clean solution, but in my case I needed to clean up the sdcard anyway.

If formatting isn't an option, try the other answer posted here regarding .nomedia files, I had no success with it as I was unable to find those files.


FWIW, I had a similar problem. After installing CM10, I could see the photos from my previous stock ROM on the phone, but not from my PC when plugged in via USB.

What I did was I used AirDroid to download the files to my PC, delete them using ES File Explorer, and then re-upload using AirDroid.

  • That is one way to solve the issue :) Still strange why this happens to begin with, as the files are obviously "there".
    – pzkpfw
    Commented Jan 13, 2013 at 16:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .