I have created a draft message using the standard HTC Desire message application. However I now want to delete the draft.

When I select the thread I see my previous message, and my draft text below. I select "Menu", "...More", and then "Delete" and am warned I am about to delete entire thread. Which is stupid. I want to delete my draft.

How do I delete a draft?


Just figured this one out having had the same problem myself (HTC Desire HD, Android 2.2)....

From the "All Messages" view, press the Menu button. A "Drafts" icon appears (a floppy disk icon) - press that, and it takes you to a view of all your drafts.

Press & hold a draft message to View/Delete or press the Menu button again & select Delete Drafts to go to a view where you can bulk mark the drafts you want to delete.

Hope that helps!

  • Brilliant! Well done, after several weeks of scratching my head you have provided the answer. I hope others upvote you too! – PP. Dec 17 '10 at 10:38
  • hi i have a same problem too but i cant' found A "Drafts" icon i already press the menu button, and i just see compose, delete threads, search, & settings where's a drafts icon? please help me – user3580 Mar 21 '11 at 14:51

just clear the text of the draft message, and it will automatically disappear

  • Actually, no. When I delete the text of the draft, and press "back", then next time I select the thread the draft text is back. -1 for untested answer. – PP. Nov 21 '10 at 10:15
  • actually I've been doing it and it always worked. – Louis Rhys Nov 23 '10 at 16:59
  • What version of Android and manufacturer, Louis Rhys? I am using Android 2.2 on a HTC Sense phone.. that could be the problem.. – PP. Nov 26 '10 at 9:09
  • Doesn't work for me. 2.2 Desire Z – Nick Apr 15 '11 at 18:20
  • I have T-Mobile G2 (USA), which is supposed to be the same hardware as a Desire Z. My SMS app is called "Messaging" (green, square cartoon talking bubble), version 2.3.4 (Gingerbread version). In this version and in Froyo, when I clear the text, "draft" goes away" in the thread display. I have no "drafts" button in my button bar after pressing "menu". – benc Sep 20 '11 at 14:07

Have you tried pressing and holding on the text of the draft message and then using the context menu to delete that single draft message?

  • That's what Louis suggested, and it doesn't work. The draft reappears when you reopen the conversation. Aaron has it right! – user2668 Feb 2 '11 at 20:33

protected by ale Mar 24 '11 at 12:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.