I think that I had this feature in my Galaxy S way back in the 2.1-2.2 era, but now I can't figure it out on my Galaxy Nexus (takju, 4.1.1).

What I'm looking for is this: if I have the phone locked in my pocket and I receive a call, after I finish it, I'd expect to be able to return the phone to my pocket with no extra hassle. However, after the call I'm thrown into the recent calls list and have to back my way out from the app and lock the screen. And despite the oh-so-buttery experience of Jelly Bean, this usually means frantic back-tapping, waiting for the phone to exit to the launcher and annoyed grunts, or - if I have an app open under the lock screen - accidentally closing said program, reopening it, browsing to the wanted section and, well, annoyed grunts.

This is by no means a difficult task, but it's annoying as I have to do it every time.

Oh yeah, another thing: if I call someone and the line is busy or he/she rejects my call, the screen locks. Doesn't matter what state the phone is, you'll be thrown into the lock screen. Why? Why can't this happen after received calls?

I apologise for the ranty (is that an adjective?) tone, TGIF.


You can use Lock Screen After The Call. For more details, visit this link.

| improve this answer | |
  • This is almost what I wanted, except that it locks the screen even if it was not locked before the call. The ideal solution would be to lock the screen only if it was locked when the call started. – onik Jan 12 '13 at 10:44

What ROM are you on, stock or custom? If custom, which one? If you can be persuaded to move to a custom ROM, try ParanoidAndroid's latest for the Galaxy S (assuming that's the device you currently have). No such problems with their ROMs. I have it on two devices.

| improve this answer | |
  • Sorry, left it in the tag only, I'm on Galaxy Nexus (takju) 4.1.1 stock/vanilla. I prefer vanilla ROMs due to the phone being used in development. – onik Sep 21 '12 at 5:51
  • Should have noticed the tag. OTA update or manual flash? If manual flash, try reflashing. I am no developer but every single ROM flash has taken me twice or thrice to get everything right. Maybe I am the unluckiest flasher (no pun intended) ever. – I-O Sep 21 '12 at 6:02
  • I first flashed manually to takju 4.1 from yakjuxw 4.0.4, then OTA to 4.1.1. All my flashes have worked on the first try, if buggy alpha relases aren't counted. – onik Sep 21 '12 at 6:05
  • Let us know if you managed to get this solved. – I-O Jan 11 '13 at 2:34

I've got the same device (takju, 4.1.1) and I don't have the issues you mentioned. I've been using exDialer as my dialer for some time, so it might be my default dialer, or it might be something else. Try exDialer and see if it does the trick.

I'm not fully confident of my suggestion as I'm not sure whether the dialer can really have this effect. But it's worth a try.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.