I have tried the suggestions here and here with no results.

Google suggest changing back to @googlemail.com, waiting two days and restarting the phone, but that hasn't worked either.

Anyone had any luck with this?

  • Good question! I want an answer to this, lots of people having the same problem: google.com/support/forum/p/Talk/… – Dan Nov 28 '10 at 19:55
  • May be silly question, but have you logged your phone in with the new @gmail account? I went through this grief a while back... I'm racking my brains to remember how I got past it - will let you know as soon as I do! – FoleyIsGood Nov 29 '10 at 23:15
  • @foleyisgood: Thanks, but yeah I had tried that. Jim posted the 'solution' that I ended up using below. – Mike Speed Dec 13 '10 at 10:47

I had this issue with my old G1. The only resolution I was able to find was to do a factory reset on the phone and re-enter the Google ID with the @gmail.com extension, as OS version I was running does not have the ability to remove your Google account.

Newer OS versions do seem to have the ability to remove your Google account from the phone and re-enter it with the new extension as I've been able to do this on Froyo at least.

  • Yeah, this is exactly what I ended up doing. It's a real shame it has to come to this though! – Mike Speed Dec 13 '10 at 10:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.