I carry two Android devices: my Nexus S phone, and a Nexus 7 tablet (both running Android 4.1 "Jellybean"). The tablet has Wi-Fi, but no cellular radio; so in order to use the Internet with it when there's no Wi-Fi hotspot nearby, I have the phone set up for Wi-Fi tethering: it effectively becomes a Wi-Fi hotspot, and the tablet uses that for Internet access. This works perfectly.

However, I recently discovered what appears to be an alternate method of tethering: Bluetooth. Both devices have menu options that seem to allow it; here's screenshots of how I configured both devices:

Phone Tablet
Options on Phone and Tablet (click images for larger variants)

I tested this by turning Wi-Fi off on both devices, then opening the browser on the tablet and refreshing the page that happened to be loaded. I saw a message that said

    Unable to connect to the Internet

I was, of course, hoping to see the page reload.

It's a shame that I cannot get this to work, because it promises one advantage over Wi-Fi tethering: easier security. I want to prevent other people from stealing my bandwidth; with Wi-Fi, this requires that I set up a WPA password, and then get that password onto the tablet somehow (which is quite tedious). But with Bluetooth, all that's required is that I "pair" the devices, which I've already done.

So I am wondering if I'm doing something wrong, or if this feature simply doesn't work.

  • On my JBed galaxy nexus it works between desktop and phone no problem. This could be that the tablet isn't setting up routing information properly or similar.
    – ewanm89
    Commented Oct 1, 2012 at 10:50
  • I haven't tried recently, but I think my Mac laptop can use the phone's Internet connection via Bluetooth ... so that certainly would implicate the tablet. But it still doesn't tell me if the tablet is buggy, as opposed to me somehow misconfiguring it.
    – offby1
    Commented Oct 1, 2012 at 20:10
  • Out of curiosity, I tried again: now it's working. What's different is that the tablet is now at Android 4.2, and the phone is Cyanogenmod 10. Here's the tablet's settings screen: dropbox.com/s/ud44bvj1cd3e7mp/… and here's the phone: dropbox.com/s/b88ezz4ucan7hsz/…
    – offby1
    Commented Nov 18, 2012 at 22:43
  • 1
    I was able to make a Bluetooth tethering connection between my Nexus 7 and Galaxy Nexus without trouble (both on 4.2). I noticed that the BT icon on your N7 screenshot hasn't turned blue (which indicates a good connection). Could be a basic BT connection issue. If you continue to have trouble, try testing a different kind of connection, like sharing a file via BT.
    – Mr. Buster
    Commented Nov 30, 2012 at 22:11

6 Answers 6


Maybe this is too late for some of you but this is a solution for Android 4.2:

Basically you need TUN module since the standard configuration does not include it: Google Play - TUN.ko installer

Bluetooth thethering - fix solution


Some Background.

There are two distinct modes for WiFi.

(1.) Using WiFi between one or more devices and an Access Point (AP). This includes what happens when setup a device as a WiFi hot-spot for other devices.

(2.) Using WiFi as an ad-hoc network, between two devices.

By default, Bluetooth operates like (.2), and allows for sub-devices (keyboard, speakers, microphone, etc.) to be attached or 'paired' to a different device.

You need to identify whether you can have your non-cellular capable device pair with the cellular-radio service of the other device. This would first require that device to 'publish' this as a Bluetooth sub-device (or 'service'), and then for the other device to be able to 'discover' it.

None of this is impossible, but some of the pieces may require extra drives or settings not currently available (or configured). Good Luck.


On my stock Transformer tablet (running ICS 4.0.3) and my Galaxy Nexus phone (running JB 4.1.2), I first had to pair the two devices, then enable internet sharing on the phone, then in the Bluetooth settings of the tablet touch the phone's item in the paired devices list. This activates the internet connection sharing. It seems that the sharing doesn't happen automatically; that is, the tablet doesn't automatically fall back to the bluetooth device even if there is no wifi available.

  • I did all the steps you mentioned.
    – offby1
    Commented Dec 9, 2012 at 0:08
  • @offby1: And? It works for me every time. Are you sure the phone is sharing its connection over BT, AND that you started the connection on the tablet? Commented Dec 10, 2012 at 2:31

I wonder whether you're confused - as I was - with the presence of the tick and the wording 'Use for internet access' on the profile page?

Once the devices are paired - when it asks you to confirm they're both showing the same numeric code - you have to set one phone to offer a bluetooth tether, and then on the other press the 'Use for internet access' line - with the tick that looks like it means it's already working. It'll show 'Connected to device for internet access' and the tick will stay on. The tether-offering phone will say 'sharing this phone's internet connection' on the tether and hotspot screen.

Sometimes I find the connection refuses to stay connected for more than a second or so. I have no idea which phone isn't cooperating, but when they're in that mood it generally means I have to disable both bluetooth interfaces and start the tether one again, first.

I've raised a bug report with Google about the fact that the language should read less ambiguously: 'Will use for internet access' or 'Not connected to device for internet access' or similar, to emphasise that it's not currently being used. I've raised a similar complaint about the tick remaining ticked whether the connection is active or not.


Figured I'd check in again :) My phone and tablet are both running 4.2.2; bluetooth tethering has been working perfectly for months. There must have been a bug in 4.1 that got fixed in 4.2.


I had the same problem . Finally, I figured it out. It's a bug. The JB device fails to register the connection parameters (DNS) for Bluethooth network after connecting to tethered device and uses DNS of default wifi connection to connect, so the request fails with a timeout.

Rooted users can fix the issue using a set of commands in terminal, either using ADB or Terminal emulator.

Terminal Emulator/adb

  1. Connect the Bluetooth tether and uninstall Terminal emulator .If you are using ADB, connect device to PC through USB (in USB debugging mode) and run the command

    adb shell 

    to enter into the shell.

  2. Enter su grant super user permission to Terminal emulator when prompted.

  3. Use the command netcfg to list the available interfaces. You can find the Bluetooth interface in the list. It may be btn0 or btn.

  4. Set the network status of btn0 (Bluetooth interface) to up by entering:

    netcfg btn0 up
  5. Run DHCP to get an IP address:

    netcfg btn0 dhcp  
  6. Set the DNS of your choice:

    setprop net.dns1;
    setprop net.dns2;     
  • on my device the interface is bt-pan but... this dont work :P
    – Arnold Roa
    Commented Nov 20, 2015 at 15:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .