Ever since I got the JRO03O OTA from Verizon on my Galaxy Nexus, I've been having problems retrieving email over a 3G/4G connection. After the sync times out (I assume it times out, because it takes awhile to give up) I get the message "Couldn't connect to server." When I'm on a WiFi network, email retrieves without problems.

The account in question is on my own IMAP server, running on Ubuntu 12.04 server on a VPS. The server configuration has not changed in any way since long before I started having these problems - this started when the OTA came through. My server listens on the newer non-standard ports, 587 and 993, so Verizon doesn't block them - they no longer allow the standard ports 143 and 25 in my area, and more and more ISPs and coffee shop hotspots are blocking them now in favor of the secured IMAP ports.

I do have a secondary account on this phone - a corporate Exchange account, which has no problems retrieving email regardless of what network it's on.

This leads me to two conclusions:

1) The problem isn't in the server or the network. I'm not seeing it with my tablet (Nexus 7), only on my Galaxy Nexus - and only when on the Cell tower networks. Even if I have my tablet tethered off the GNex, indirectly using the cell networks, the tablet has no problems connecting to my IMAP server, but the phone fails to connect.

2) The problem is not related to Exchange, as my corporate account has no problems over either WiFi or 3G/4G. The problem is restricted to my personal IMAP account, which is set as the default email account on this phone.

I'm not sure if it's relevant, but the company Exchange account is not configured on the Nexus 7, just the IMAP account, and of course, my Google account, but that's through the GMail account.

I've done a lot of searching, but can't seem to find a solution. Does anyone have any ideas?

Cheers! Lou


Running into the same problem....adding more info:

I just had my Droid 4 upgraded to 4.1.2. When trying to configured IMAPS, I'm getting the same error. I run the IMAP server I'm connecting to, so I can do some additional troubleshooting.

I'm running dovecot as an IMAP server. Here are the log messages:

dovecot: imap-login: Disconnected: Inactivity (no auth attempts): rip=x.x.x.x, lip=x.x.x.x, TLS handshaking
dovecot: imap-login: Disconnected: Inactivity (no auth attempts): rip=x.x.x.x, lip=x.x.x.x, TLS handshaking
dovecot: imap-login: Disconnected: Inactivity (no auth attempts): rip=x.x.x.x, lip=x.x.x.x, TLS handshaking

I also ran a packet capture. The phone goes through the TCP 3-way handshake (SYN, SYN-ACK, ACK), and then does nothing. No packets after the last ACK. That probably explains the inactivity message in the dovecot log.

In the configuration, I told the client to use TLS (Accept all certificates), use port 993. I have tried multiple 'Authentication Methods' (auto, plain, etc). Nothing worked.

These settings (IMAPS, 993, auto) worked fine on 4.0.4

  • This is not an answer to the question. If you have the same problem, wait for an answer. If not, do a search. If none of the results solves your problem, create a new question. :)
    – geffchang
    Mar 29 '13 at 15:04
  • 1
    While not directly an answer to the question, knowing what things haven't worked can be equally valuable. Even partial answers can have value. I think this is fine to stay.
    – ale
    Mar 29 '13 at 15:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.