I run android-x86 as VMware image, and I dedicated the whole second display for it. Display's resolution is 1024x768, but resolution in android is lower, it seems something about 800x480. Is there a way to change physical display resolution in Android to fit monitor resolution? I have a root access to the device.

  • 1
    I know on VirtualBox you have to force it via the VBox config, so it's possible you may have to do something similar on VMWare. In other words, there was basically no way to do it within Android, it was dependent on the virtual machine's configuration. Oct 5, 2012 at 13:39
  • @eldarerathis Really, I was able to set needed resolution by modifying kernel boot options. See my answer below for details. Thx for comment!
    – Prizoff
    Oct 6, 2012 at 13:15

4 Answers 4


Thanks to eldarerathis comment.

Indeed, I was able to set needed resolution by modifying kernel boot parameters. Instead of video=-16 in kernel boot options I use video=uvesa UVESA_MODE=1024x768 and all is working in native monitor resolution!

More detailed description is here (in Russian language).

  • Thank you very much. it's a pity that all search results shows how to do this in virtualbox not VMware workstation. but is there anyway to make these settings permanent?
    – user101729
    Apr 23, 2016 at 12:57

I tried several screen changers. The one I like best is:

Resolution Changer

May not work on X86 though.


You could try LCDDensity to create the effect of a higher resolution. Not sure how this would look in a VM though.

  • LCDDensity will not work. It doesn't change physical resolution, but only dpi.
    – Prizoff
    Oct 5, 2012 at 10:13

A good option is to edit the GRUB boot loader and put vga=ask at the end of the line. This will pop up a menu asking you which resolution you want to run the device at every time you boot. Higher res = more overhead. Off the top of my head, mode 333 works reliably (1024x768@16-bit color), and I have a little better luck with 16-bit color modes and standard VGA/HDTV resolutions

The currently-accepted answer works well if you always use a certain mode

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .