I have a Galaxy S2 that refuses to be picked up by any computer. I tried different operating systems, I tried a different USB cable, I tried debugging mode. The phone still charges fine through the port but maybe the data section of it is broken. Before I take it in for repair I just want to hear if there's anything else that can be tried? I'm thinking of doing a hard reset but don't want to lose any data. Any advice would be appreciated.

  • 1
    I guess your phone's not rooted/modded (if so, just use TitaniumBackup). Without, you can still copy over data from the internal memory (mp3, video files and taken camera images on the 16 or 32 GB) to an external micro SD card using any file explorer. Application data is not stored on the accessible part, so you have to iterate through each app and use the app's internal export data (like e.g. that of "MyTracks"), which is up to each app and sadly won't work with system settings like stored wifi credentials and such.
    – ce4
    Oct 5, 2012 at 15:09
  • 1
    What Android version you are running? If it is 4.x, you can do a full backup via the Android SDK, using adb backup -- and lateron a restore via adb restore. This would include your apps and their data, so nothing is lost.
    – Izzy
    Oct 5, 2012 at 15:22
  • @Izzy so to run through SDK, you'd need to connect the phone through USB?
    – BBking
    Oct 8, 2012 at 5:14
  • 1
    @BBking Yes and no. While it's mostly done via USB, it can also be done via WiFi -- see How can I connect to Android with ADB over TCP? plus the WiFi ADB app.
    – Izzy
    Oct 8, 2012 at 6:01

2 Answers 2


As my old electronics teacher told me, check the power then the physical connections before doing anything else....I have spent 3 hours trying various fixes on my phone, all to no avail. was working fine, then around the time of the most recent update it failed to connect (Hence software fixes searched for first). I finally thought I would try to clean the usb port on the phone...(compressed air had not worked) I had some copper soldering wick and a very small screwdriver, turned the phone off (Removing battery would probably be a safer bet in hindsight as well) and rubbed the copper mesh around every surface inside the port...works perfectly. Possibly many of the issues with using a different cable could be fixed the same way.


As usual, a factory reset is a possible last-ressort to sort things out and see whether the problem is software-related. And even if the problem remains, this way you don't need to worry about your data in alien hands :)

As a factory reset wipes all data (and 3rd party apps) from your device, you of course want to backup as much as possible, to be able to restore it later. Without root, this get's a little complicated -- but not impossible, if you're running Android 4.x. Since starting with ICS (4.0), ADB supports a Full Backup of non-rooted devices.

Which brings us to a seemingly chicken-and-egg problem: You cannot establish an USB connection, which is the most common pre-condition for an ADB connection. But fear not, there is a solution for that as well: You can connect Android with ADB via WiFi as well, and there's even a little app called WiFi ADB to help you with that1:

WiFi ADB Titanium Backup

WiFi ADB makes it easy to debug/test your Android apps directly on device via WiFi TCP/IP connection. No need to use USB cable.

Trouble again is this requires root. Having a rooted device, you could of course also use Titanium Backup to backup your apps and data2.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .