3

I'm stuck with the generic IMEI (004999010640000). I've tried a number of the various workarounds (GSII_Repair, manually deleting the /efs folder, flashing stock and trying both of those from stock, re-flashing CM10 and trying from CM10 again...) with no luck. I was actually missing files in my /efs folder before flashing stock, but even with the full /efs folder I can't find my actual IMEI. So am I screwed?

  • 1
    Have you tried all the suggestions from here? – Chahk Oct 5 '12 at 16:09
  • All but the video showing to echo AT+EGMR=<imeistuffhere>, but I can't find anything about that for US phones (the video and everything else I see is referring to multi-IMEI devices, and there are two parameters that I'd like to know the meaning of before I try this on my phone). – ND Geek Oct 5 '12 at 16:27
  • Also, it appears that the /dev/pttycmd1 device doesn't exist on the i777. – ND Geek Oct 5 '12 at 19:01
  • How did you flash stock? Did you do it through Odin with re-partition? – Matthew Read Dec 10 '12 at 18:49
2

Your handset is not damaged, not totally.

But you do need to get some professional help, someone who is willing to carry out the procedure in restoring it, provided that someone has the necessary tools at their disposal.

However, you can fix your IMEI using a highly specialized but expensive repair box such as Z3X, NSPro, to name but a few.

Mostly, smartphone users do not have access to them and only repair labs or specialists have them.

  • This is what I suspected after quite a bit of searching. I've since decided to just live with it, as it's mostly not a problem. The main time it causes trouble is if someone reports a phone using it as stolen, which has happened to me twice since I first lost the IMEI, but not recently. It's also troublesome for apps that use it as an identifier, but in one case it's worked to my advantage. – ND Geek Mar 8 '13 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.