I don't have much hope. Here is what's happening

Galaxy S GT-I9000 keeps crashing at startup :
com.sec.android.provider.logprovider crashes

and other ones android.process.acore

So I cannot reach any settings to disable some system settings like Settings/Privacy
So I cannot connect usb (it's never seen by my PC)

And a very good joke : it cannot be put in recovery mode !
Does nothing

Somebody have notices some i9000 in this case : http://www.addictivetips.com/mobile/fix-3-button-combo-download-recovery-mode-in-samsung-galaxy-s-gt-i9000/ Too bad I can't do this : "Now plug the USB cable into the phone. Start a new command prompt window and navigate to the folder/directory where you have installed ADB." As my phone is not able to make the usb work !

So is there a way to reset the phone the hard way ?
I mean by opening it and erasing the memory to revert to an empty phone fully ...

PS : I cannot tell the android installed on this phone. It's not mine. All I know is that it's pretty old and that it's a custom "Orange" ROM.

2 Answers 2


Did you try this:

  1. Turn the power off. If your Samsung Galaxy S is frozen, pull the battery out and reinsert it
  2. Hold the Volume Down button
  3. Press and release the Power button
  4. You are now presented with a menu that allows for Fastbook, Recovery, Clear Storage, and Simlock
  5. Select Clear Storage by pressing the Volume Down button
  6. Press and release the Power button
  7. Now simply confirm your decision: Volume Up for YES and Volume Down for NO

(Source: KnowYourCell.Com -- the first hit on a little Google Search)

UPDATE: Alternative approaches are listed at Hard-Reset.COM, e.g.:

  1. charge your battery fully before doing a hard reset
  3. Keep pressing these 2 buttons + press Power button for 2-3 Seconds
  4. Release only power button, but KEEP pressing Volume up + Home Buttons (or VOL UP + DOWN)

You also might check with the following question here: SGS doesn't go to download, recovery mode nor does it connect via USB after installing a battery MOD

  • It doesn't : the phone simply starts and boot. I am going to try this trick youtube.com/watch?v=GjDkShT-65Y
    – Christ-OFF
    Oct 7, 2012 at 8:32
  • I just edited my answer and added a second approach (and source). Maybe you have more luck with that.
    – Izzy
    Oct 7, 2012 at 12:25
  • Volume UP + Home and power for 3 seconds helped me get into recovery. Jan 29, 2015 at 14:14
  • That was "Option 3" from my last update – thanks for confirmation, @OstapAndrusiv!
    – Izzy
    Jan 29, 2015 at 17:56

Thanks all for your help I can confirm that :

  • I had a rom (from Orange France) without any way to put my phone in download mode
  • The little device here http://galaxy-download-mode.blogspot.ch/ works
  • I was then able to upgrade my GT-I9000
  • And now Home+Vol down + power works (so not download mode was not an hardware issue)
  • now I am upgrading my phone from 2.3.6 to ... (I don't know yet I'll what version the phone can hold)
    – Christ-OFF
    Oct 18, 2012 at 6:30
  • total non-sense device, don't buy it
    – caub
    Jun 7, 2014 at 12:29
  • I know that it looks like total non-sense. But IT WORKED
    – Christ-OFF
    Jun 7, 2014 at 16:35
  • you can access the recovery modes with volume+home+power, just switching between volume up ad down does sometimes the trick
    – caub
    Jun 7, 2014 at 17:06
  • I know that. I tried that but this recovery WAS NOT available with the rom installed
    – Christ-OFF
    Jun 7, 2014 at 20:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .