I've seen many questions on this site asking about the famous space problems in Android phones. None of those I've seen helped me and since none of them asked about my phone, I'd like to present a new case.

I have three memories, and this is a table showing the usage:

Screenshot usage

What's most bothering is how an advanced phone like this would have such basic problems. I've tried:

  • setting the default installing path to the SD card: No such setting.
  • moving apps to the SD Card using apps like App2SD: Some cannot be moved.

I really don't know what else to do. Am I really forced to delete apps? I don't want to delete any of those I've installed (they are 14), why should I do that with over 9 GB of free space available? I'm just hoping there's an option I missed.

  • 1
    All images taken by camera/audio mp3s that you use get stored on sd-card by default. Some apps cannot be moved to sd-card based on their manifest.
    – t0mm13b
    Commented Oct 9, 2012 at 19:33
  • @t0mm13b Ah yes, I forgot: since it's a new phone, I have no MP3, no photo, nothing.
    – Alenanno
    Commented Oct 9, 2012 at 19:35
  • what are the 14 apps? (Google maps is one biggie that refuses to be moved to sd-card which is enough to drive me bananas!)
    – t0mm13b
    Commented Oct 9, 2012 at 19:37

2 Answers 2


I have solved my own problem today and I'd like to provide the solution for others that might encounter it. The actual Internal memory for this phone should amount to exactly 0,96 GB or close to that. I got aware of this comparing my phone to another one from the same model. I first tried formatting the Flash memory (or Mass memory) on my phone, but to no avail. So I tried doing a reset and it solved the issue.

To do this:

  1. Go to Settings.
  2. Choose Privacy.
  3. Select Factory data reset or the corresponding example in your native language.
  4. Wait for the phone to do its thing. You should see some code/script running on the screen. Now wait.
  5. When everything is loaded and you configured the minimum settings, open the application Task Manager. You should be able to see the correct size.

Many people have that kind of problem and I have the same one. I finally figured out and it works great. I have a Galaxy Tab 7 but many android devices will experience that.

There are 2 important folders. the /system has a lot of system stuff. The one called /data is actually not really just data but it is where Android install the application apk and some of the data related to it. If you force the apk to install on SD card, it will still use some of the /data space (small amount) for some data.

Be aware that there is a confusing "sdcard" name usage. Most Android devices have a "sdcard" that is an internal flash configured like an SD card but the real external SD card is often named external_sd or something along those line.

The problem I discovered is in /data/tombstone, you will find 10 files named tombstone_0#. These are debugging info collected by android or at least that's what I found googling it. You want that if you want to debug applications and need longer information than "logcat". But, you don't need that for a normal user. Delete all of them. These 4 files were using 1.4GB of my 1.89GB internal tablet storage.

To do so, you will need to root your device. Yes, you must. And it won't explode don't worry, I've done it and many others too! Then get a program like "Root Explorer" to browse and delete the junk. It will request and be granted root privilege if you rooted your device before and you will be able to do whatever you want.

To root your device, just google "root android my device model" and you should find quickly how to root your device.

  • 1
    Tombstones are what is called "core dumps" on Unix/Linux systems. To my experience, there are rarely more than 10 "tombstone_nn" files in that directory -- and your case is the first I see where they occupy more than 10MB (see also this answer). And if you look again: more than 100MB tombstones would be almost impossible for Alenanno, as the internal partition is only 126MB altogether...
    – Izzy
    Commented Oct 10, 2012 at 6:43
  • Thanks Sylvain but I was looking more for standard methods, not deleting files. Why is there no option for me to use the Flash Memory if the Internal is so small? This is what I cannot understand and it makes me thing I'm missing something on my phone.
    – Alenanno
    Commented Oct 10, 2012 at 9:55
  • 1
    @Sylvain Though the tombstone folder is accessible without root, the tombstone files unfortunately are not -- see my remark there: Unfortunately, all tombstones are owned by system, and permissions are set to rwx------ -- so if that's your troublemaker: you cannot remove them without root
    – Izzy
    Commented Oct 10, 2012 at 20:20
  • @Izzy. Thanks. My mistake, I read to quickly. And I like your full answer you are pointing too. Commented Oct 10, 2012 at 20:25
  • Thanks -- and I know that feeling, happens to me from time to time, too :) And I'd wish there was at least a button somewhere to tell the system: "Cleanup dumps, I cannot read that stuff either" -- especially on non-rooted devices, who should read that? Only makes sense on development devices.
    – Izzy
    Commented Oct 10, 2012 at 20:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .