I have Galaxy S3 with baseband version I9300XXLFB and I'm having problems when it is connected to the PC. I cannot transfer or retrieve any files or data over USB.

When I plug it in to my PC, it tells me USB device not recognized and the S3 does not appear anywhere for me to access it. I've tried different cables and PCs and they all seemed to exhibit the same issue. How can I get this working?

  • 1
    Is Settings > Developer options > USB debugging ticked?
    – t0mm13b
    Commented Oct 11, 2012 at 15:15
  • Is the device unlocked at the moment you plug it? Have you checked the device manager (in case you're using Windows 7)? Commented Oct 11, 2012 at 18:33

11 Answers 11


You may need to use Samsung KIES (software for PC), or get your PC to recognize the 'new' "MTP" USB mode.

further background:

Ice Cream Sandwich supports USB mass storage after all, Galaxy Nexus does not

Wikipedia >> Media Transfer Protocol

Samsung >> SUPPORT >> Kies 2.0

Also see: Can I disable MTP mode and just have a regular USB connection?


For anyone having trouble connecting to Windows using USB in MTP mode, make sure you install the Samsung USB Driver for Mobile Phones from Samsung's website. Here's a link for the Verizon model:


Navigate to the Manuals & Downloads tab, and then below the tabs, click Software. There you will see the USB driver listed.


I had a similar problem connecting my Galaxy S3. The drivers were not installing properly. There were messages saying the USB device as malfunctioning. Despite being able to charge the phone, it was not being recognised as a mass storage device nor offering me an option on the phone as to what I would like it to connect to the PC as, until I changed my USB cable.

I had read some posts that had suggested this. After trying all the phone and device manager settings from debugging to reinstalling and updating drivers, this is what worked: trying a new USB cable. The drivers installed themselves. Then, I was able to select Use as Media Device from the phone notificaton menu. I double clicked My Computer, and opened Phone to display media. I was also able to select USB tethering from phone settings to allow connection to the internet, which is what kicked this all off in the first place.

Hope this helps some others.

What I also discovered during this process was how to set the phone up as a wi-fi hotspot. I just followed a neat youtube video detailing this, and was able to connect my laptop to the internet while I sorted out the rest of my problem.


I had a similar problem, but with no error message. My computer just did not see my phone even though the computer recognized any other USB device i put in. Note: on a previous session my computer DID recognize my phone and I was able to b/u some files.

My final solution was fairly simple, while the phone was still on I removed the battery from the phone and left it out for 5 minutes. Then I reinstalled the battery and turned the phone on. After plugging the phone into my computer via the USB cord I had a connection phone to computer.

No, I do not have a technical explanation for this.

  • This didn't work for me, but in opening up the case I did discover that it was desperate need of a cleaning, so it was helpful in that regard.
    – nateirvin
    Commented Apr 24, 2014 at 16:45

Have a look to the following Steps

Step 1 # Try cleanup and reinstall of drivers

Step 2 # You can to use Samsung KIES (software for PC), or get your PC to recognize the "MTP" USB mode.

Step 3 # Make sure you install the Samsung USB Driver for Mobile Phone

Step 4 # For file transfers, you can use Airdroid, which connects through wifi.

  1. Install the latest driver
  2. Ensure you are using the factory cable that came with the phone (some cables wont work with the S3, the computer will even lie to you and give you error saying the "USB device not recognized")

Just use KIES AIR (pre-installed on your S3). Works perfectly and is user friendly.


Before updating my Galaxy S III to Android 4.3, didn't have any problem with Windows 7. It's obvious that W7 should have recognized it even if Kies software were not installed. That was with main before updating to new android. But saddlery W7 was not able to find the Galaxy SIII in Media device (MTP) mode!

Solution for me:
Installing: Device(Install),USB Drive (Software) - Nov 9, 2012


you might need to clean the micro usb port. Try using a toothbrush or a safety pin to get the lint out. This worked for me


You need to use USB 2.0 ports only.


If you are using Android 4.3 open the dial pad and dial *#0808# Android 4.2 *#7284# this will solve your problem.

  • What, exactly, do those codes do? How will they help?
    – ale
    Commented Aug 26, 2014 at 15:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .