5

My relative is running CyanogenMod 7 on her HTC Incredible. Recently, her phone started acting weird in that when connected in a phone call, pressing the touch tone keypad is not working. You can hear the tone being pressed in the speaker, but the other end of the phone call is not getting the tone transmitted.

What might be causing this, and how could I go about getting this fixed?

7 Answers 7

1

In Settings - Phone settings

or

In Dialer - Menu -Settings

You'll find an option for DTMF. Try changing that to different values. It might even have been turned off.

3
  • I'm not finding either of those in the settings for CM7.1.
    – WilliamKF
    Commented Oct 14, 2012 at 12:56
  • @roxan Are you sure it's from this version?
    – Secko
    Commented Oct 14, 2012 at 17:58
  • Actually no. I assumed after reading couple of post this is where it should be. Guess I also have to take my answer down :)
    – roxan
    Commented Oct 15, 2012 at 3:35
2

I don't even know if this will work, but after having this problem intermittently on an AT&T Samsung Galaxy Note 4 and not being able to find DTMF settings anywhere, I found this: Settings > Device > Personalization > Accessibility > Dexterity and Interaction > Press and hold delay (options short, med, long)

On a T-Mobile Samsung Galaxy Note 4, it was similar but not exact: Settings > Personalization > Accessibility > Dexterity and interaction > Press and Hold delay (options short, med, long)

I selected long.

I can't take credit for this; the idea came from someone making a post about a Samsung Galaxy S7, whom I wasn't able to thank but wish I could.

2

I have an international Samsung Galaxy S III (I9300). I got this to work under CM 11 by opening the Phone app, hitting the dotted line for settings, and then un-checking the "Dial pad touch tones" option.

I can't hear the touch tones anymore, but at least I can access my voicemail.

1
  • My problem was the opposite. Dial pad touch tones was disabled. When enabled, tones started to be transmitted again, though unfortunately annoying touch pad tones are now audible. This is probably changing as Android goes through each iteration, so worth toggling the Dial pad touch tones setting.
    – AlainD
    Commented Nov 5, 2021 at 11:13
0

I had a similar problem of not hearing the touch tones. It turned out to be that the volume for "Music, video, games, & other media" was set to the lowest level. "Settings > Sound > Volume" Maybe this will help someone.

0

The solution that worked for me is very different.

My mobile is a Lenovo K8. After searching a lot, nothing worked for me, and based on Lenovo call support, this worked finally: Network & Internet > Mobile Network > Enhanced 4G LTE Mode [DISABLE]

Disabling this only worked for me, changing the Touch & hold delay to different values [short, medium, long] also did not work.

Hope this helps someone. Definitely, this is a bug. However, no updates were also sent to my phone.

0

I just had this problem for 2nd or 3rd time. I'll say what happened in case it helps.

I'm on Samsung Galaxy with Android OS. I was in a phone tree; to get to the keypad, I backed out to the home screen and opened the phone call icon (for new calls), but the keypad didn't work for the phone tree.

There's a screen that shows after you start a call, it has a red end call button. You have to get back there and hit the keypad option, then it works. To get back there, I swiped down from the top of the screen and it showed my active call with a button that brought me back.

-1

On the Samsung Galaxy S4, I changed to option "long" instead of "normal" and it worked:

  1. From the Keypad tab, tap the Menu icon (located in the upper right)
  2. Tap Settings
  3. Tap Call
  4. Tap DTMF tones
  5. Tap Long
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .