When I attach my Galaxy S to my home wifi network it will stay connected for about 1-2 minutes. After this the wifi icon will be enabled, however no connection seems to actually be there.

I've tried a few wifi re-enablers on the marketplace but they haven't been successful.

  • Is it possible for you to check the logs on your home wireless router? I wonder if there's some wireless protocol issues causing your device to be disassociated. One thing to try if it's available to you, change your wireless router to 802.11g mode only (i.e. if you supported 802.11n then force it to g only) – PP. Nov 25 '10 at 9:05
  • It's a linksys wireless-n – Chris S Nov 28 '10 at 13:08

I would start at the router and look there first. Do a reboot of the router and see if it still happens. if it does, there should be logging in the admin of the router that you can turn on (if its not already) and maybe you can see something causing the drop.

Try getting Wifi Analyzer from the android market (free) to check if your router is on the same channel as other networks around you. try to put your router on the "clearest" channel.

| improve this answer | |
  • That's a very useful app, I tried it and it seems to be the phone as I'm exclusively on Channel 12. – Chris S Jan 12 '11 at 9:36
  • I think that is the way to go. Try another network or router. I had a Linksys Router that was always dropping the connection on my iPod Touch and I never really found any solution other than changing the router. Since then I didn't get any disconnection. – jmbouffard Feb 3 '11 at 15:40
  • It appears to be my router after getting a new one. But wifi analyzer helped out a lot – Chris S Feb 14 '11 at 15:50

go to Settings -> Wireless and network -> Wi-Fi settings, then press the "menu" key at the bottom of your phone. Click on "Advanced", then on "Wi-Fi sleep policy", it should have the option of "When screen turns off" but change it to "Never" if you don't want it to drop your Wi-Fi and use your phone service provider's data network when your screen turns off.

| improve this answer | |
  • 1
    Doesn't seem to be the problem when reading the description. The wifi icon is still there but no connection is actually working. – jmbouffard Feb 3 '11 at 15:36

That happened to me because the network was handling b g and n bands, if you set only n in the router, the problem is solve.

| improve this answer | |

Is it dropping while you're actively using it? Then is probably a router problem, or possibly a defective phone. Try on another network.

Otherwise, try using RyanZa's One Click Lag Fix. You don't need to actually use the lagfix, just open the app and change the WiFi Timeout value to something higher.

| improve this answer | |

If you have JPY firmware then it might be causing problems. Try JPU/JPX

And try also other modem.

Hopefully it will help!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.