I have updated my contact photos in my phone and then I wanted to update my google contacts. The sync of contact data is working fine, but the photos aren't being synced.

Is there anyway I can fix this?

I have Samsung Galaxy S3 with ICS 4.0.4

  • Does your pictures sync the other way? (I.e. upload a picture on the web interface, does it sync to the phone?) If not, make sure contact sync is actually enabled in the settings, or if there are any sub-settings to the contact sync where pictures perhaps is disabled. – pzkpfw Dec 12 '13 at 9:58

Sorry, I don't have enough rep to comment, so I just ask you here:

Can you please try to:

  1. Create a contact on your phone
  2. Log in to http://contacts.google.com/ with your computer
  3. see if it get's on the contacts website after you've created the contact on your phone
  4. Change something in the contact on your phone (phone number)
  5. See if it updates in the contacts website

If it doesn't update you have a contact sync issue.

Go to:

Settings > Accounts & Sync > (your google account) > Sync contacts

This must be enabled.

Check the last sync time, is it recent?

If this all doesn't help. As a workaround try to add a contact picture from the contacts website and check if it gets updatet into your phone. I manage all my contacts there as it is easier.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.