I have an HOTT MD500 MID. Previously, when I plugged this into my computer, Thunar found two storage spaces, the first being the microSD card, the second, another storage space inside the device. Recently, I wanted to reinstall the device, so I first used gparted to reformat both of these storage spaces to FAT32 filesystems, then used the factory reset option on the device.

During the reformatting with gparted, and error appeared preventing me from reformatting the internal storage. Now, when I plug the device into my computer, Thunar no longer can see the internal storage space. Also, when I go to Settings --> SD card & MID storage, “Internal Flash Storage” reports “Available Space 0”, while the “MID system storage” reports “Available Space 79 MB”.

I found some similar threads at Is internal storage formatting harmful?, which did not work for me, and Missing internal flash memory and SD card does not mount, which provides instructions specific to another model, but which I do not know how to adapt these instructions to my model of MID. Using the factory reset option in my device did not seem to help.

  • Why is the internal storage no longer visible in Thunar? How can I restore it to its original state?
  • Is that normal that “Internal Flash Storage” is reported as “0”? Will this give me any problems?
  • You mentioned that an "error appeared" while trying to format the internal storage. What was the error message?
    – Wyzard
    Commented Oct 17, 2012 at 12:39
  • I do not know and cannot recreate the error as now my computer can no longer see the drive.
    – Village
    Commented Oct 18, 2012 at 11:24

3 Answers 3


Why is the internal storage no longer visible in Thunar? How can I restore it to its original state?

I do not know how to adapt these instructions to my model of MID

First of all you need to get adb working (Android Debug Bridge if you want to learn more). Specific information regarding this is available at ADB for Android Developers (ARCHOS Internet Tablet) as linked in the answer you provided.

When you have adb ready, you should be able to run adb shell. This will give you the ability to give commands to adb and we can start accessing the device. I'm quoting the answer you linked here:

If the connection is OK, it will start a server and after e few seconds show the '$' prompt. this means you are connected to the tablet and have direct access to the linux shell. If you type 'ls' you will see a list of folders that contain the operating system and all supporting files that make your tablet work. Now navigate to the folder containing the Flash file system by typing:

cd ./dev/block/vold

If you now type 'ls' again you should see three or four folders that have numbered names. One of them is '31:8'. This is the folder that points to the internal flash. Now we can fix our problem by recreating the MS-DOS (FAT32) file system on this partition. Type the following:

mkdosfs -F 32 /dev/block/vold/31:8/

This will fix the FAT32 filesystem. Now leave the shell by typing 'exit', disconnect the USB and restart your tablet. On my system this made internal storage re-appear, and after that it also mounted the sd-card. Problem solved.

Please follow these steps and report if it works or not, please supply any error messages and I'll try to help you further to the best of my abilities.

Is that normal that “Internal Flash Storage” is reported as “0”? Will this give me any problems?

This is likely just due to the fact that the internal storage isn't detected by the device. It doesn't necessarily mean that it's broken or lost forever.

I'd also like to add as a final point that messing with the partitions on the internal storage is usually a very bad idea. Don't do it unless you know exactly what you're doing and why. You should always assume that messing with partitions can lead to data loss.

  • I have also formatted my internal storage ( I know I am dumb) and a tried your solution. Everything worked well until mkdosfs -F 32 /dev/block/vold/179:0/ (I used 179:0 because it's the internal sd card on my huawei ideos s7 slim). Now it says mkdosfs: can't open '/dev/block/vold/179:0/': Not a directory. What did a do wrong?
    – Tamas Koos
    Commented Mar 16, 2015 at 17:05

The problem is likely that the internal SD card to FAT32. While this may not stop Android from working it does screw up many file system related commands/programs, permissions, etc.

Android usually uses ext3, ext4, or yaffs2 for the internal SD card. The manufacturer may be able to tell you which is the one they use. You can also try formatting the internal card to ext3 and doing a factory reset; if it already successfully installed to FAT32, it shouldn't have any problems with an EXT file format.

If in fact the manufacturer does use FAT32 for the file system (which would be very odd), it's possible that it uses a different cluster size than how you formatted it (ie 4, 8, 16 or 32 kb), and the file utility is relying on that information to determine sizes and it is incorrect - producing a nonsensical output of 0. Many manufacturers also encode information into the boot sectors, etc. that you may have inadvertently wiped.


Just press Power + Vol + then tap Wipe Data and press Yes. Hope this helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .