I recently traveled to another country and I'm using a local prepaid sim card on my Galaxy S2.

My prepaid credit was depleted rather quickly, and when I checked the phone record I found out my phone was sending two sms messages each day, about one minute apart from each other - one to my old number and one to my wife's number (as far as I can tell the only thing special about my wife's number is that with my old sim card I used to call it a lot).

These two numbers are in my home country, so the sms messages were very expensive, and that is why my prepaid credit was depleted so quickly. Of course I didn't send any messages myself, nor is there any record of them in the outgoing messages.

Now that my credit is depleted I still sometimes get a message from the mobile carrier saying they can't deliver a message I was supposedly trying to send (though really I wasn't) because I have no credit - so my phone is still trying to send these messages. Specifically this also happens after I restart.

So I'm stuck with no credit, and I don't want to recharge my card because my phone keeps trying to send these messages and it will deplete my credit again.

Obviously some application is sending these messages, and to find out which application (after reading this question) I installed RL Permissions, and here are all the applications listed as having the permission to send sms messages:

apps that have sms sending permission

Now as far as I can tell all these apps came preinstalled by Google or Samsung, and therefore supposed to be trusted.
The only exception is WhatsApp, but this is a widely used app and I think is also trusted. It does make me wonder though, why WhatsApp needs permission to send sms messages in the first place - it's supposed to send messages only by using the internet connection isn't it?

So can anyone help me find which app is the culprit?

  • 1
    You should also check to see which of these apps has the permission to start on boot. It should help narrow down the selection. Also, do you have the message that was sent to your wife (by asking her, as you stated you don't have the message in your outbox)? The message would probably help you (or us) narrow down the possibilities even more.
    – Stephen S
    Oct 19, 2012 at 19:55
  • @dymutaos - I actually tried to put my old sim card in my device to see the sms message, but it was too long after the message was sent, and I didn't get it (I guess there's a limit to how long the mobile carrier saves a message for me if my device can't receive it). Same goes for my wife who is with me and also changed her sim card. Anyway I solved the problem (see answer below).
    – Joe
    Oct 20, 2012 at 16:09

1 Answer 1


I am such an idiot.

A picture is worth a thousand words:

enter image description here

When I bought my device, about a year ago, I turned on the feature "SIM change alert - Send SMS when SIM card is changed". I completely forgot about it later, and it only came back to me today. Of course the recipients I defined were my own number and my wife's.

The lead I followed was @roxan's comment, which raised the suspicion about the mobile tracker app. A Google search led me to this forum post that describes this security feature, and when I read it I recalled that I turned it on.

Despite this incident, I actually still think this is an excellent feature that can really help in case my device will be stolen, but I just have to remember to turn it off before I change the SIM card myself...

  • I'm having this problem and it's eating up my balance every time I restart the phone. I tried to get into this "SIM change alert" setting, but it just crashes Settings app with "Unfortunately, Settings has stopped"... I don't know if placing the old SIM will make the settings work, but I know this thing is sending messages out every time I restart phone, but I can't get into the settings and change it!
    – ADTC
    Nov 17, 2014 at 8:07
  • @ADTC - Have you tried Settings > Application manager > "Settings" app > "Clear data"? (from here: android.stackexchange.com/a/75836/13108)
    – Joe
    Nov 19, 2014 at 11:07
  • Thanks but actually I resolved the problem already. I had disabled the Samsung Account app. After I enabled it again, the Settings app didn't crash and I was able to authenticate and disable the feature.
    – ADTC
    Nov 19, 2014 at 11:18
  • 1
    @ADTC post this as a solution to the question...
    – Beveloper
    Aug 25, 2018 at 21:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .