I've been trying for a few hours to update my Desire S running Android 2.3.5 to the newly released official ICS rom "RUU_SAGA_ICS_35_S_HTC_Europe_14.01.401.2_Radio_20.76.30.0835_3831.19.00.110_release_275068_signed".

Running XP, I've installed the latest HTC Sync from the HTC website (to get the drivers). No matter what I try I always get stuck at the screen "Verifying information on your android phone. Please wait...". I've let it sit there for over an hour without it ever continuing, I'm not getting any kind of error message.

When using the HTC Sync program the phone shows up as connected without any problems. I've tried running the installer both while having the program on and having the phone in "HTC Sync mode", and having the program turned off and having the phone in "Charge only mode". USB debugging is of course turned on. I've also tried turning the AV and firewall off, just in case. I've also tried resetting the phone to factory settings, just for the hell of it. No change.

The phone is not rooted and is S-ON. I've tried restarting both phone and computer a number of times (phone both using fast boot and regular boot) but I just can't seem to get it working.

Any ideas?

Edit: I also found a log file from the RUU, containing the following:

    <T170112><DEBUG><PAGE>====== WelcomeDlg ======</PAGE>
    <T170117><DEBUG><PAGE>====== VerifyingMobileDlg ======</PAGE>
    <T170117><DEBUG>strPath = C:\Program\HTC\HTC Sync 3.0\
    <T170117><DEBUG><CMD>adb devices</CMD>
    <T170118><DEBUG><OUT>adb <T170118><DEBUG><CMD>fastboot devices</CMD>

2 Answers 2


Found a solution myself. The problem was that the adb and fastboot tools in the HTC Sync program didn't work. I solved it by downloading the Android SDK, installing platform-tools, removing HTC Sync from the path variable and adding the platform-tools directory in its place.


yzfr1's answer helped!

When I installed HTC Sync there was only adb.exe but no fastboot.exe, using adb.exe and fastboot.exe from the SDK and putting them in HTC Sync's directory solved the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .