I'm trying to install Cyanogenmod on my Samsung Epic 4G. I've tried a couple of ways to get Clockworkmod Recovery on the phone, but every time I boot it into recovery mode I get the stock recovery program. I've tried the method listed on the Cyanogenmod wiki here and one using Odin here, but every time it boots, it loads up with stock.

Does anyone have any ideas for how I can get around this?

2 Answers 2


It looks like the key was holding down volume-down, power, and camera buttons until the capacitive buttons (home, search, etc) lit up, which was longer than until the screen flashed (as stated in the CyanogenMod wiki).


First of all, you need to to flash clockwork mod recovery over your default stock recovery.
Then get into Clockworkmod recovery.
After that you can flash any CynogenMod roms.
Use this guide to work with Odin.

  • That was not the issue. Using various guides I did install clockwork mod recovery "over" the stock recovery, unfortunately the guide you linked does not provide further information from the ones I already linked. Additionally, the problem was how to get into Clockworkmod recovery, which you didn't address. Apparently the Epic 4G (not the Touch) keeps a copy of the stock recovery somewhere which it boots if you don't hold down the noted buttons for long enough.
    – neromir
    Nov 8, 2012 at 15:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .