3

My Galaxy Nexus, Jelly Bean, was set to Automatic Date & Time, Automatic Time Zone, and the correct Time Zone was shown: "GMT -03:00, Brasilia Time". Here in Brazil Daylight Saving Time begins today. Android didn't detect that.

To be fair Microsoft for many years also made the DST start in the wrong week in its Windows products. If I recall correctly, it required a new law from our Government to make the DST more predictable, so in the last few years Windows got it right.

I don't know if Android will make the DST start in the wrong weekend or if it won't work at all. How can I correct it?

  • Doesn't your clock get auto-adjusted by your carrier? – ale Oct 21 '12 at 20:44
  • @AlEverett Apparently no, is there anything I can set to make it happen? – Jader Dias Oct 22 '12 at 10:37
  • It could be that the Telephony layer does not understand the semantics of NITZ which is transmitted over the cellular network... this is highly dependent on the RIL layer to handle this for you. – t0mm13b Mar 19 '13 at 16:41
4

You will need to research how to set this on Galaxy Nexus and Jelly Bean, but ..


You are currently using "GMT -03:00, Brasilia Time", and this does not include Daylight Savings by default.

You need to instead use (one of):

 America/Bahia
 America/Sao_Paulo

These all use UTC -2:00 for DST.

See: Wikipedia: Time in Brazil

0

It could be a bug in JB, as every country seems to have its own rules for Daylight Saving Time. Brazil changed the rules in 2011.

Not all regions in Brazil observe DST, so you can try a to specify a city/region that does observe DST.

http://en.wikipedia.org/wiki/Daylight_saving_time_by_region_and_country#Brazil

0

When I use "Automatic Time Zone, use network-provided time zone" it gives me "GMT -03:00, Brasilia Time".

When I set it manually, there's only one option with Brasilia in its name: "GMT -02:00, Brasilia Time". Using that corrects the issue and gives me the proper time.

0

the problem is that you're getting your clock updated directly through your router configs.

you should change the clock settings in your router in order to get this fixed, as your time and date configurations come directly from it because Nexus 7 doesn't have a SIM card from which it would obtain local time.

Best wishes.

  • 1
    I haven't mentioned Nexus 7. I said Galaxy Nexus. It has a SIM card. – Jader Dias Oct 25 '12 at 11:09
0

Android like most popular mobile OS has 2 options as has been indicated above 1. Manual time setting.(by not selecting auto Time and Time-zone option) 2. Automatic time/time-zone setting from connection/network provider.

You would get these under setting(under system tab/category), if you search for time.

Now for 1 as is obvious. You have to set it back/forward during DST/DST over days. For 2 you have to select both automatic Time and Time-zone option from network provider. It does not work if you select just automatic time.

However even with both of them set to auto, some network provider don't have enough towers to handle and distinguish between 2 regions one which has DST and which does not. The only solution in this case to manually set the time-zone based on your knowledge of what it should be.

This should help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.