2

I have a new Android 4.0 device (d2pad), and I have installed Google Drive and Google+ but neither one works. When I try to start Google Drive it gives me the message "No Google account found, exiting". I poked around and tried to find where to create a Google account, but on the account screen I don't see a Google option. How can I create a Google account, or what do I need to install to create one?

I see the following options on the add account screen:

  • Facebook
  • Corporate
  • Email
  • Dropbox

Corrective actions tried:

  • Installing "Google Play Services" from the marketplace.
  • Resetting to factory defaults
  • Installing "Google Play Services" again

I also can't log into Google for my marketplace login.

6
  • 1
    What device do you have?
    – Martyn
    Oct 23, 2012 at 18:10
  • Perhaps, more importantly, who is your carrier?
    – ale
    Oct 23, 2012 at 18:11
  • @AlEverett No carrier.
    – C. Ross
    Oct 23, 2012 at 18:26
  • @Martyn cheapo d2pad.
    – C. Ross
    Oct 23, 2012 at 18:27
  • I did some research and kept running across "Google Service Framework", but I can't see how to install that.
    – C. Ross
    Oct 23, 2012 at 18:30

5 Answers 5

1

I'm afraid the hardware you have bought isn't an official Android device, and so won't have google account options available to you. I'll try and find a work around for you.

1

I have a D2pad as well and I am successfully using google+. like Mike C said, go to Settings>accounts&sync>add account (top right corner). There will be 4 options to choose from. Corporate/DropboX/Email/Google. Tap google and sign in to your google account. now that you setup your google account, open 1mobile market search and download and install google+. Hope this helps

5
  • OP already said that they have no "Google" option on the account creation screen.
    – Chahk
    Oct 24, 2012 at 3:00
  • Yeah, I have Facebook instead of Google. Considering a factory reset ...
    – C. Ross
    Oct 24, 2012 at 16:48
  • I just did a factory reset and still don't have a Google account option. :-(
    – C. Ross
    Oct 24, 2012 at 17:22
  • there's a firmware update if you go to d2pad's website. d2pad.info/…. hope that helps
    – Danny
    Nov 8, 2012 at 13:16
  • @Danny Thanks, but no apparent change...
    – C. Ross
    Nov 12, 2012 at 20:23
-1

Once you have an active Google account, which you can create here

https://accounts.google.com/SignUp?continue=https%3A%2F%2Fwww.google.com%2F&hl=en

On your Android ICS device, go to:

Settings>Accounts>Add Account

you'll see many options from which you can choose, among them Google.

Generally you can add an account by running a google app, such as reader, play or gmail, and it will ask you to sign in with your google account.

1
  • Sorry Mike, I don't see an "Google" option on the account screen.
    – C. Ross
    Oct 23, 2012 at 17:57
-1

some people have found work arounds for this problem. i haven't tried myself but it looks like there are 2 ways it can be done. here is the linkhttp://www.androidtablets.net/forum/allwinner-a10-based/47980-can-anyone-help-me.html

1
  • 1
    Welcome to Android Enthusiasts. Please avoid answers that only contain a link because your answer becomes useless if the link is broken. It would be best if you include the essential parts in your answer and provide the link for reference.
    – THelper
    Oct 23, 2012 at 19:56
-1

It looks like your device isn't approved by Google, so sadly, you can't officially get Google apps for it. It also seems to be a pretty unknown tablet from an unknown manufacturer, so there isn't a community around it who might have unofficial versions.

However, if the tablet is just a rebadged version of something more popular (like many of these tablets are), this program might help you identify the actual manufacturer and get help that way.

2
  • Answers should stand on their own. It looks like the best part of this answer is behind that link you left.
    – ale
    Oct 23, 2012 at 19:58
  • Alright, I've edited it to point directly to the program now. Oct 23, 2012 at 20:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .