5

While uninstalling some app I may have accidentally uninstalled Google play app.

But even then I have updated Google play app before and while uninstalling it should remove only updates from my phone not the complete app. I should have been able to use default app. But I am unable to do so.

Yesterday while clicking app's icon it was showed an error, that app isn't installed. I tried to find it on my app library but it's not there.

What should I do?

I am using Samsung galaxy fit (GT-S5670)

  • Try rebooting. As per you your phone is not rooted and its not possible to delete system app without root. – roxan Oct 28 '12 at 4:42
  • @roxan I tried but still no luck – Random Thoughts Oct 28 '12 at 5:04
  • I have posted link for downloading apk as answer. – Random Thoughts Oct 29 '12 at 4:48
4

Yes, downloading and installing the APK should work as long as you have the Google Framework Services -- basically if the Market worked before, then it will again unless you removed system services. (Those can be replaced as well but it's more hassle).

  • How can I check I have system services or not? – Random Thoughts Oct 28 '12 at 4:03
3

As @Matthew Read suggested I search for an apk over net and found one.

Here is a link: Google Play Store 3.9.16

Note: After installing apk to your device if app started force closing

  1. Clear data from app i.e go to settings->manage app->play store->clear data
  2. If it is still force closing reboot your device

This works for me hope works for others as well

1

If your phone is rooted, then you of course have a chance that an app could have flashed something that could remove the GAPPS and Google FrameWork Services, but if you don't know what I am talking about then your phone is not rooted, and you simply need to download Google Play Store. On the other hand, if you are missing GAPPS, then you can re-flash it depending on your version of Android: http://goo.im/gapps/

  • No my phone was not rooted. I checked the link you provided but I don't understand how to download and which one. – Random Thoughts Oct 28 '12 at 4:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.