I have Samsung Galaxy S (GT-I9000) and I've installed Cyanogenmod 10 M2. I can reboot into recovery from Cyanogenmod (Hold Power button, select Reboot and Recovery). However, I cannot boot directly to recovery holding Volume up + Power or Volume up + Home + Power when the phone is powered down.

Do I need to do something to the phone hardware to get some button combination to boot to recovery mode? As far as I know, the button combination I've tried is the correct one for this device. I can boot to download mode with Volume down + Power.

The recovery is the one installed along the official galaxysmtd Cyanogenmod 10 M2 ("CWM-based Recovery v6.0.1.4").

I would want to fix the issue because now I'm afraid to flash ROM updates because getting into recovery in case of boot loop is much harder if I cannot get the normal key combo to work.

  • Try removing the battery, then holding the buttons while you reinsert it. I'd also try other combos such as both Volume buttons + Power. Oct 30, 2012 at 21:55
  • 1
    I'm now suspecting that there's something wrong with my recovery image. When I insert battery with Volume up + Power, it looks like some kind of boot loop while entering recovery: the galaxy s default boot logo shows up, then screen goes black for a moment, then cyanogenmod logo shows up, the screen goes black for a moment and then galaxy s default boot logo shows up after a moment. And the loop goes on until I release Volume up. Then it boots to full Cyanogenmd 10 M2 after a black flash or two. Oct 31, 2012 at 6:49
  • I don't understand how it can still enter recovery when rebooted from Cyanogenmod - perhaps the hardware is in different state in that case and the recovery kernel is able to deal with it. Oct 31, 2012 at 6:50
  • Interesting. I'd recommend flashing a recovery with Odin. (By the way, Odin will also save you if you can't boot into your ROM. It only relies on the bootloader.) Oct 31, 2012 at 15:12
  • 1
    Another try might be: Power off your phone. Hold Power, Vol Up and Home Button. Wait for galaxyS logo then release Power button! For me that is the proper combination.
    – theodm
    Oct 31, 2012 at 21:39

4 Answers 4


OK. I found the correct combination. It seems that the recovery distributed with Cyanogenmod 10 M2 for galaxysmtd is really picky about the hardware buttons.

Here's how you can boot to recovery:

  1. Start with Galaxy S powered off
  2. Press and hold Volume up + Home
  3. Press and hold Power button
  4. Wait for (factory default) Galaxy S GT-I9000 boot display to show up
  5. Release the Power button before the second boot display with text "Cyanogen(mod)" shows up. Keep holding the Volume up + Home buttons.
  6. Wait for Recovery to start. After you see the recovery menu, you can release the Volume up and Home buttons.

If you fail to release the power button before the second boot display, you cannot get it to go into the recovery mode. Instead it will enter the normal boot sequence which seems to fail if you keep holding the Power button. On the other hand, if you don't keep buttons pressed long enough, it will enter the normal boot sequence, again. I haven't figured out if holding the Home button is really required but at least it does not prevent entering the recovery mode.

  • It turns out that at least with my hardware, holding the Home button is required. If I don't press the Home button, the bootloader seems to halt. Holding Power for 5-10 seconds reboots the device, otherwise nothing happens. Nov 5, 2012 at 10:35
  • It's also worth mentioning that Galaxy S (GT-I9000 international version) has hardwired behavior to do hardware reset if power button is hold for 5-20 seconds (the delay seems to be random). The OS (Android) cannot cancel this so it does not matter if you have screen lock or a phone call active. I've accidentally rebooted my phone while holding gloves (the power button is on the side of the phone and will be accidentally activated very easily if one grabs the phone while wearing gloves because it's too cold outside to do without). For the first time it happened, I thought the OS had crashed. Jan 16, 2013 at 7:48
  • tried but didn't work :( cm 9
    – numediaweb
    Mar 23, 2014 at 22:31
  • @numediaweb: are you sure your hardware is GT-I9000 and not e.g. GT-I9000M or GT-I9000B? Could you elaborate how it "didn't work"? Did it reboot continuously or did it enter the normal boot sequence, instead? Mar 25, 2014 at 12:30

For anyone that arrives here via Google like I did, here is how I got into Recovery Mode:

Device: Galaxy S i9000M (the int'l version of i9000) ROM: CyanogenMod 10 (CM10)

The three button combo that used to work (Vol Up + Power + Home) did not work. However, holding BOTH volume button and power (no Home) launched me into Recovery pronto.

Hope this helps out a fellow Google traveler.


  • The GT-i9000M or "Samsung Galaxy S Vibrant" is different phone than GT-i9000 (known as international version of "Samsung Galaxy S"). Looking at the specs, GT-i9000M looks like a better hardware because it contains gyroscope -- assuming of course that it works otherwise correctly with galaxysmtd CM ROM. May 21, 2013 at 12:47

For me work: vol up + home + power (release power after showing Galaxy S GT-I9000 boot display and continue with vol up + home)


Hold the power button as you usually do for "power off". Then, select the option "recovery"; it will enter into the recovery mode.

  • 1
    The question is how to boot into Recovery when the phone is off. The OP knows they can do it when the phone is on. "reboot into recovery from Cyanogenmod (Hold Power button, select Reboot and Recovery)"
    – Peanut
    Apr 14, 2013 at 19:26
  • Yeah, reading more than the first sentence of question would help a lot in the future. The point was how to get into recovery in case the OS is boot looping / crashing during startup because in that case you cannot ever see any menu provided by the Android. Apr 16, 2013 at 5:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .