I tried factory resetting so I need to enter my Google account again to my device however it's been more than an hour now and Google Play still says "You don't have any devices". Any ideas how to fix this?

  • Contact Google... – Android Quesito Nov 2 '12 at 10:52
  • Are you getting this on the web store or on the device? It doesn't make sense that it would happen on the device. Have you tried upgrading Google Play? – Matthew Read Nov 2 '12 at 17:12
  • @MatthewRead The device works fine. The web store doesn't. – IMB Nov 2 '12 at 18:43

Try following (Worked in my case)

  1. Remove Google account from settings
  2. Clear data of play-store and Google services framework
  3. Restart phone Now access play store again.
| improve this answer | |
  • I know this works but in my case this time it didn't work. – IMB Nov 2 '12 at 11:41
  • Worked for me. Without removing the google account it din't work. – Lucky May 18 '15 at 7:43

Try to install some apps. directly on device using Google Play, then you will find your device after sometime, happened to me many a times.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.