2

I have a problem with my Google Nexus S. Yesterday I was out in the city and my battery meanwhile died and the phone shutdown. The next day when I charged the phone, I noticed that it is showing no signal even when there is signal. I've turned it off and on a couple of times. I also tried a different SIM from a different service and it didn't show signal either! Also I tired those SIM cards on a different phone and it works.

The big mystery for me is that until the battery died yesterday I made calls from this phone with no problems, and until now I never had problems with this phone.

When I go to Settings -> About phone -> Status, I see that Network shows unknown and Service state shows out of service. Is there anything I can try resetting?

  • Yes I did, but with no result – user23191 Nov 4 '12 at 6:28
  • Yea.. I realized that later, as you mentioned that you tried different SIM as well. Obviously, you had to remove SIM and battery. Silly me! – Suraj Bajaj Nov 4 '12 at 7:38
  • Your SIM tray may have some problems. See if the connectors (not sure what it's called) are not bended. Try lifting the connectors up a bit. This solves problem in most cases. Also, blow some air to de-dust it. – Suraj Bajaj Nov 4 '12 at 7:45
  • I also had this problem few months ago, but it was fixed very quickly with an update from Google (I was lucky with that update from Google). From what I observe (from my experience) at Google Nexus S, this problem appears when battery die and the phone it shutdown. And I guess that this a soft problem. – user23191 Nov 4 '12 at 9:32
  • Ohk.. If that is the case then a reset might help. You can also try flashing a custom ROM, if you are comfortable. – Suraj Bajaj Nov 4 '12 at 14:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.